Unable to login or sign up

I have problem with login , when i try to sign up it say i have to login when i try to do so its ask me passcode when i say i forgot its take me to selfie mode to click and send when i do so it says not recognized. Its lyca sim i requested for some kind of solution but no help from the sim provider as i feel its used by some other user with same phone no.

@Kamalvk Hello, Welcome to the community. :sunflower:

  1. Could you please check if your app is updated to the latest version available? After that, can you please clear your cache for the Revolut app, and try again? Here, you can see how to clear device cache:

iPhone: Go to Settings - General - iPhone storage - Search for the Revolut app - Then click in on “Offload app/clear cache”.

Android: Go to Settings - Apps - Search for the Revolut app - Then click on the app - Click on Storage - Click on “clear cache”.

  1. Could you please try to ‘kill’ the app (close it completely from the app switcher), reboot your device (turn it off and then on), and try again? Let me know if it worked. :pray:

Veda | Community Team

Hi i have tried as requested but its not working and
Unable to identity. I think my phone no got registered with some other user (old one)

@Kamalvk Could you please follow the steps mentioned here and try again? :eyes:

  1. Tap ‘Lost access to my number’ on login page
  2. Enter your old phone number and passcode
  3. Provide your email address
  4. Enter your passcode and follow instructions
  5. If you fail more than three times, you’ll be directed to the in-app chat support

Veda | Community Team

Not helpful its not working, until revolut De-link other user who is registered on my phone number.

2 Likes

@Kamalvk Hello, Welcome to the community. :star_struck:

As we would require more details from you can you please contact us on help@revolut.com? This would help us look into the issue and resolve it asap. :pray:

Veda | Community Team

1 Like

Hi, I have the same problem, I’ve tried several times for the last week and gone through the whole process (I’ve emptied the cache, reset my phone, updated the app)
I wonder if my phone isn’t too old for the selfie mode (2017)

2 Likes