Top up issue with MasterCard


#1

Hi,

Few days ago I’ve managed to successfully top up with my MasterCard. Trying again today gives an error saying I need to activate 3DS. So I did - I activated 3DS for this card but the same error message appears again and top up fails. Support seems is not aware of the reason and has no idea how to solve this - they told me 3DS is not supported at all and I should continue trying in both modes (with and without 3DS activated). Ofc, it didnt work. Then I’ve registered another card - VISA - that has 3DS activated. The top up was successful , Revolut app has loaded the verification screen and everything worked fine.
So seems it is now broken for MasterCard only (note again few days ago the same card worked fine).


#2

Had the same problem yesterday. Spent 1.5h with support. Didn’t get any further than canned responses. It was clear they are not aware or don’t want to be aware.


#3

P.S.: My Mastercard is from TransferWise.


#4

Have exactly the same issue here. New MasterCard debit card from transferwise. Balance on transferwise is several 1000 CHF. Tried to top up my Revolut CHF account with the new TransferWise card.
First I have a daily TopUp limit of 250 GBP, which is annoying but not a “bug”.

However, I cannot top up at all as Revolut app is telling me to “activate 3DS”, which I cannot with TransferWise.

Please get this fixed…


#5

Same for me, same for many people too…also using TW card.
Maybe TW didnt’ like we use their card just to top up Revolut and blocked something (even if they say no…)


#6

So it seems there is an issue with Android. People with iOS seems to not have this issue.
Wait and see, AndreasK is working on it, see here: SWITZERLAND - Most cost-efficient top-up methods


#7

Hmm. I am on iOS and it didn’t work until yesterday. Reading this I tried again and it now works. Haven’t updated the app since, so whatever was fixed was server side.


#8

I’m also on iOS and now it works fine to me. Thanks to the one who fixed it. :slight_smile:


#9

Hi,

I was having the same problem. I managed to top up before using a Maestro card with 3DS activated. I was redirected to the bank page to enter the 3DS code I received by SMS. Some days later I tried to top up again and the 3DS authentication failed. I confirmed with the bank that everything was ok with the card and that they add several authentication errors logged in their servers. I then realized that revolut does not redirect you to your bank 3DS page after your first use of the card, and it seems to me that they try to automatically authorize. But the bank of my Maesto card does not go along. The workaroud I successfully used was to remove my card from the top-up methods and add it again. Revolut considered as it was the first time use and redirected me to the 3DS page.

Revolut support, could you please confirm my finidngs?

Thanks!


#10

I am still having this issue. Does anyone still experience this bug?


#11

I can’t add my TW card as one of the top up card either. It says “something is wrong”. In fact I cannot add any cc/debit card as top up card, so unless I get my salary directly paid into my Revolut account. I cannot use it.