Not recognising photo


#1

I have tried several times to upload my passport photo which is not recognised. The system is processing my latest input for very long and doesn’t give me feedback whether activated or not. I need the account activated soon so as to receive my salary in uk there


#2

I am in the exact same situation ,have tried several times and now it says I have reached my yearly too -up limit ,I have just joined the app two hours ago !


#3

Hey both, you need to contact the in app support in order to do a manual verification. Sadly this can take some time as they are received many requests currently.

A verified account have very low limits.


#4

Please read this help article

https://www.revolut.com/dk/help/getting-started/verifying-identity/why-do-i-need-to-verify-my-identity

There are several explaining the ins and outs of verification and why it must be done :slight_smile:


#5

Could you please let me know how to contact the app support?


#6

Through in app support. Type “live agent” to get past Rita.


#7

Hi there. Thank you for your patience. I’ve escalated this issue to the relevant team which is better suited to help you with your request. Please note a member of the team will contact you via in-app chat shortly.


closed #8