Cannot log in and forgot passcode link does not work

I cannot log in to my Revolut app - it does not accept my passcode anymore. I got an email from support with instruction to click the link " forgot passcode’ and follow the steps , but when I click the "forgot passcode’ link then I get a message ; “sorry something went wrong” and a red X so I cannot continue?? What to do?

3 Likes

I already fixed the issue. I uninstalled the app and downloaded the latest version, and then the ‘forgot passcode’ option actually did work. So I sent a selfie and got the option to create a 6 digit passcode. Now it works fine again, case closed. - The only thing I would like to point out is that, now I know the issue was having an old version Revolut App, and I was never informed to upgrade it?! As users we should get a timely notification when we need to download a new version instead of just letting the old version stop working and then having to figure it out yourself.

4 Likes

@Nick123 Hello, Welcome to the community. :heart_eyes:

We’re glad to hear you were able to resolve the issue by uninstalling and reinstalling the app! We understand your frustration about not being notified about the need to update.

We appreciate your feedback and suggestions.In the meantime, you can always check for available updates by visiting the app store on your device. :pray:

Veda | Community team

2 Likes

I have same problem tried to log in saying forgot passcodr keeps saying somethinh wrong with red x

2 Likes

@Marian01 - uninstalled the app and downloaded the latest version, then you can follow the usual steps to fix it.

2 Likes

I downloaded the new version 4 days ago and still cant get access
I would apreciate your help,

1 Like

Hello everyone :wave: ,

Welcome to our community. We are sorry that you are unable to log in to your account. :frowning_face:

@Marian01 , Have you tried the following troubleshooting steps?. :arrow_double_down:

  1. Make sure your Revolut app is updated to the latest version available
  2. Clear the device’s cache: iPhone: Settings > General > iPhone storage >
    Search for the Revolut app > Click in on "Offload app/clear cache;
    Android: Settings > Apps > Search for the Revolut app > Click on the app >
    Tap on Storage > Clear cache.
  3. “Kill” the app (close it completely from the app switcher)
  4. Reboot your device (turn on and off)
  5. Try with both Wi-Fi and mobile data - ensuring that network connection is strong and stable
  6. Use an alternative device (if possible)

After finishing these steps , please try to reset the passcode again and let us know if you face the same problem. :pray:

@Helenak , May we know are you getting any error message? :thinking:

SG | Community Team

1 Like