Cannot add a new beneficiary in Android app


#1

I’ve just started using the Android app and I can’t add any beneficiaries.

Basically all my money is stuck inside Revolut.

What happens when I fill the new “Add new beneficiary” form is that the “Add beneficiary” button remains grayed out.

I’m using the version 4.13.1 on a Google Pixel.


#2

Hi there. Thank you for contacting us.

Could you please send me a screenshot?


#3

The app in Android probabbly has problem at this point of adding new beneficiary. I tried from two different phones and not a chance. The add beneficiary field , after introducing all the dates, is not activated, doesnt become red to be able to activate it. But on Iphone , it works! Please do something. Thanks!


#4

And even if the previous step were made, the send operation is still inactive. I was thinking that are just some small problems, but you still have to work to make it to work. Please repair the faults to be able to use it.


#5

Here’s a screenshot from my phone. As you can see, after filling in all fields the “Add Beneficiary” button is still disabled.


#6

im struggling too

got the app a few days ago and using it to make my first payment to someone in singapore.

Trying to add there details. Af first the mistake was mine as i had china highlighted and it would not accept the bank account number. Then i realised they were in singapore and it would then allow me to add the account number.

However, no matter what i put in the mob number field and email, which both claim to be optional. it does not let me. It briefly flashes add beneficiary when you first start but then greys its self out. using pretty old samsung a3 but with android 7?


#7

Try completing just the mandatory fields and leave blank the optional ones (email address and Mobile phone).


#8

Hi all
I am a brand new user and I’m having the very same problem - whilst trying to add myself as a beneficiary the “Add Beneficiary” button remains greyed out.
I have tried logging out and missing out the non mandatory fields but still no success


#9

same here, but tried again this morning and found the phone number needs to be of the country code you are sending too…crazy; I left it out and worked.


#10

you mean you cannot do international transfer ?


#11

I left the phone number out and it loaded the beneficiary ok. Then I did a test transfer to France. Took weds thru following tuesday to get there.


#12

Also stumbled upon this now. I was able to “force” the app to create the beneficiary by:

  1. Removing e-mail and phone number of the beneficiary
  2. Removing and adding first two letters from IBAN in upper case. It started with “cz29” for me, so I replaced with “CZ29” and it worked.

But I noticed that the “Add beneficiary” is greys out after a while anyways. Feels like server-side validation. So the trick for me was to do the changes and click on “Add” before it greys out. :man_shrugging:t2:


#13

I encountered a similar issue when trying to make a transfer to a singaporean account. By trial and error I found out that the problem was with dashes in the account number. It’s a common way to put it in SIN but Revolut doesn’t accept it.
Anyone aware if omitting the dashes could cause any problems with the transfer landing in the right account? Will the payment get processed and attributed to the the account it’s supposed to?

Cheers,
V.


#14

This is getting really frustrating. I can’t add myself as a beneficiary to transfer my salary. I fill in all the fields for a new beneficiary, the app accepts all the inputs. The “Add Beneficiary” button doesn’t grey out, but when i press it, I just keep getting a pop up saying “Sorry. There is a problem. Please try later”. This has been going on for two days straight now. And the “chat help” people leave me hanging for 6+ hours and then the help resets and I have to start again. I’ve had two “live agents” just stop responding as soon as they hear my issue. My money has been stuck in the Revolut account for two days… Any ideas?


#15

Hello,
I have the exact same problem.
Have left email and phone blank, but the “add beneficiary” button remains greyed out.
On android (google pixel).
Does anyone have a resolution for this?


#16

Hi,

I’m running Android 8 on a brand new Moto G6.

I have had similar error for weeks. After entering bank beneficiary details and pressing the Add Benficiary button, I get the passcode screen, which accepts my code, and then I get the sms verification screen, which is receiving the code, but then reports “Sorry. There is a problem. Please try later”.

I have been on many chats with support via the app, over the last weeks (including today), and have been told repeatedly, that the BUG IS UNIQUE TO ME, and tht it is still under investigation.

Now that I find numerous postings here, stating the same, or similar errors, I am loosing confidence in Revolut!!!

I have an urgent bank transfer to make, which has so far been delayed for several weeks, and which is putting me under a lot of financial stress.

I certainly hope that I will get a satisfying reply here, as to what is wrong and what is actually being done to fix it as soon as at all possible. Revolut does not offer withdrawal of cryptos yes, wherefore my funds are factually frozen, besides from pulling out cash on a card.

Kindly,
Kaliya


#17

I’m experiencing the same problem.
Trying to add myself as a beneficiary so I can pull funds from my revolut account to my UK Santander account. Only I type everything in correctly and the add beneficiary button doesn’t allow me to press it.
Has anyone had a reply as to what’s causing this problem, and is there a fix??


#18

It still seems to be impossible to add a beneficiary… Does someone have a solution?