Wrong top up limit, always considering Euro


#1

Using the iOS app, when trying to top up my account and I enter some amount, it does not matter what currency I choose it always considers it Euro.

For Example I choose CZK, enter 16000 (which is about 630 Euro) and I get an error saying that I cannot top up more than 15000 Euro, which is clearly wrong:


Top-up in CZK limited daily to CZK 250 (cca 10€)
#2

are you verified? :slight_smile:


#3

Yes, that looks like a bug to me. On the other hand, have they officially confirmed somewhere that card top ups for CZK are supported now? Could be that they are still working on it, and some eager users just found out that CZK showed up and tried it out. I’m not sure.

At least, the list for officially supported currencies does not yet list CZK:


#4

#5

Yes I am verified, but I do not see this conversion bug to be relevant to that.


#6

CZK support was announced this week.

This bug is reproducible with USD, 16000 USD is about 13000 Euro and you get the same error saying you are over 15000 Euro.


#7

before you are verified top up limit is very low, so I thought that this is that case.
Now I see, that this is just a bug.
Have you told them about it using in- app chat?


#8

Yes, but their in-app support is overloaded like always.


#9

I’ll tag @AndreasK and @JessicaZ for you.


#10

Just had a chat with support. They are aware of the issue and are working on a resolution. No timeframe on a fix though.


Top-up in CZK limited daily to CZK 250 (cca 10€)
Limit is not checking the exchange rate