Won't let me "activate account" for GBP sort/account number


#1

Hi there,

Has anyone else experienced this please? When I try to top up via bank transfer, I have bank details visible for EUR, USD, PLN and CHF, but if I go into GBP, it is all greyed out with a red button at the bottom to “activate” account. However when I press this, nothing happens.

I have:

Verified all my ID
Verified a debit card
topped up ok via android pay before
logged out/into the app.

I had a live chat with a support rep, who said “someone would come back to me” but they were very non-commital about it. I am travelling in a couple of weeks time, and I need to make sure that this is sorted for then. Has anyone else had this issue before please, and does it take long to sort?

Thanks in advance!


#3

I raised this to customer services 4 days ago and didn’t get a reply from them. I chased them today and I was told that it is a bug and the developers are looking at it. Allegedly it should be fixed in a few days.

Quite disappointing that I have had to chase them, and that their support takes such a long time to respond when you get in contact with them.


#4

Same problem :expressionless: I need this account


#5

I am having the same problem! Currently waiting to be transferred to a Live Agent and been waiting ages.


#6

I’ve waited over half an hour before…


#7

It will be fixed? I`m furious…


#8

They fixed it! :))))


#9

Still doesn’t work for me…


#11

Well done! This worked perfectly!


#12

It’s 5 months since the last post on this thread, but I’ve been having this problem for a week now and have raised it with support as soon as it happened.
The only difference is that instead of nothing happening, I get a message saying “We’re sorry, something has gone wrong. Please try later”.

I use an Irish mobile number, but I do have a UK GBP bank account which I wish to top up from.
I have ordered a debit card for this account, but it has not yet arrived, so bank transfer is the only way for me to top up from that account.
My bank will not let me use the IBAN and BIC because it will not let me do an International Transfer for UK to UK and SEPA transfers are must be in EURO currency.


#13

My understanding is that the country of residence is determined on sign-up via your phone number.

As (UK) current accounts are only for UK :r: customers, this may be why you cannot obtain a GBP account number + sort code.


#14

I am having the same problem. Same error. England number. Keep chasing support. No answer no help. No one cares.
Did he problem get solved or not? It’s been a month now for me and nothing
I’m thinking just close the account. There’s no point of this


#15

Yeah, it never worked. I managed to get the IBAN top up working correctly.

If the problem was due to having an Irish mobile, then this could have been avoided if:

  • I was never shown the option to activate a UK account
  • The error message said that I needed to have a UK account, or
  • The support agents told me this was the issue right away.

#16

Account holder is probably deemed as Irish (rather than British), and therefore base currency is EUR and not GBP (with current accounts only available for UK account holders (for now(?)).


#17

UK Current account is available for people outside of UK (I am registered with +48 phone number and it is available for me in the app) and my default wallet is PLN.
It is probably the bug in app, in FAQ there is no information about only UK - https://www.revolut.com/pl/faq?lang=en#how-can-i-top-up-my-revolut-account-via-bank-transfer
Maybe you should try to completely remove the app and install it again, or in another mobile.


#18

I have a UK phone, and am UK resident, but I also still cannot activate UK account and get Sort Code/Account number . Why? The IBAN does appear but I need the UK system for DD’s.


#19

Kind of out of topic, but are you aware that Revolut does not yet support GBP direct debits, even with an activated local GBP account?

They are working on it, but no ETA.


#20

No I wasn’t. Thanks Frank. So they support Euro DD’s but not UK ones. That’s a bit limited for a 1.6 B£ UK company.


#21

I have the same problem We’re sorry, something has gone wrong. Please try later”. In both accounts for uk one and for the one in Euros. what is the solution?


#22

@Libelula Currently no solution that I’m aware of as I’m having the same problem. There’s another thread saying it’s a known bug and they are working on it. Really frustrating as I just opened a Revolut account and can’t even use it for what I want to do!

EDIT: I just logged in to the app and tried again on the off chance and it worked for my GBP account!