We're sorry, something has gone wrong. Please try later.


#1

Updated apk to latest and it is dead. Can’t login. After entering my phone number get error message “We’re sorry, something has gone wrong. Please try later.”

Time to transfer my $ to normal bank account and just move back to Revolut then needed.


#2

Just got the same issue, the update has failed and disabled the previous build so can no longer access the account.


#3

This is a global problem with Revolut. Not related to app update.
Please read:


#4

Hi guys,

Any update about this bug?

I am still unable to log in to the application after the last (official) update.

Help!

Oussama


#5

It is a global FAILURE, not a problem. Revolut business is built on TRUST.

Oh yeah “We’re really sorry for the hassle with this”. HASSLE? They are probably joking. It is not a minor hassle, it is a fucking tragedy for some.


#6

+1 with the same issue, hope they get it fixed soon, I’ve been with revolut for a good few years now but this outage and the one a few weeks ago is making me think again.


#7

Revolut response on Twitter is amazing. “Really sorry - we’re having a slight issue due to demand.” This shit is called a SLIGHT ISSUE, wow. So then what is a serious one? Hack of all customers data as happened to Uber or what?


#8

calm your tits, they said they’re working on it, they’re probably losing more money that you are atm
everyone is an expert when it comes to finger pointing


#9

Any recent update from revolut?
On Tweeter it is been mentioned that it has been fixed but mine is still not working


#10

Snap, updated earlier today, thought it was my internet connection, but even on alternative connections have the same issue. Fingers crossed, all is well…


#11

I have the exact same issue, I got my accounts a few years ago and have not used it in a while. I get the same message when it asks me to create a password.


#12

I have the same issue, I’ve wanted to send some money to a friend, and this message appears.
I’am new to Revolut, but my account is verified, I’ve added a card, i requested a card, everything is ok. So what is the problem?


#14

Hi there. I can see that you were able to create an account. :slight_smile:


#15

Seems like i was blocked even I try different number the message is still the same. However i tried to apply my number through my friends cell and it worked. But I need access through my CP not my friends phone


#16

anyway i received my card already i just need to access it through my cp and i cant do a thing with my phone


#18

Hi @o0per0o. Could you please check for outstanding updates in the Google Play/App store and then try logging in again?


#20

Is your phone rooted?

If yes, then you can try and signup via an Emulator such as BlueStacks or Nox App Player. The code will be sent to your phone.


#21

Please dont tell me Revolut checks for that :wink:


#22

It checks for some of the Google services. At least according to another thread :blush:


#23

Yes, I understood (“understood”, dont have a confirmation) that it uses some of them, possibly Google’s messaging channels, but that should be unrelated to root permissions.