Verification pending and extra charge of 6€


#1

My verification is pending over almost 24 hours (it actually just doesn’t work cause I haven’t downloaded anything yet). Nobody solved my problems although it was put here and in the in-chat that my problem was escalated to specialists who can deal with it.
What is more, they have CHARGED ME 6 EUROS for an extra card. I suppose I did sth wrong while trying to solve the problem, but how is it possible to have an extra card while I don’t have the main one?
I’m very dissapointed. I was recommended this card by my friends but this negative experience really puts me off.
Waiting for 6€ to be returned at least.
How can it be solved?


#2

Downloaded? Do you mean uploaded? If that is the case the verification isnt pending, but hasnt started yet at all.

As for the card, a second card is charged. I can understand that you might have made a mistake but you still simply ordered a paid product so you shouldnt really be disappointed.


#3

You really did something wrong I think. They verified me in 3-5 minutes after upload yesterday.


#4

Sorry, “uploaded”.
I have had this for about a day

It doesn’t allow me to upload my DNI.

They haven’t verified my docs yet, so how is it possible to issue another card if I don’t have the main one? And there was no notification about any charges.

Anyway, I haven’t had the problem solved since yesterday.


#5

So yes, the verification hasnt started yet. You need to upload that first and that is done under “More” and then “Profile”.


#6

Thanks, but this is the problem: it doesn’t allow me to upload. It says “procesando” - in the process.


#7

You were charged 6€ for the virtual card that you activated. The last sentence on the file shows clearly that you need to send additional documents and I think you need to Have an official address in the EU or Switzerland to be able to use Revolut.
If you want a refund on your 6€, just try the in-app chat and let them know that you want to cancel the virtual card that you activated by mistake.


#8

Thanks, Gekko. There’s no way to upload the documents, though. At least what I’ve tried doesn’t work. And I’ve written in the in-app chat but there is still no answer.
I’ve reinstalled the app but the problem persists.


#9

Considering you wrote the issue is already being escalated I’d assume you were already talking to an actual support agent and not the chatbot.

In that case maybe @AndreasK could speed things up.


#10

Ok, I’ll contact him as nothing has changed since yesterday and nobody replied me in the in-app chat.
Thank you!


#11

Hey Olga. Sorry for the long wait. An agent will be with you shortly.