URGENT - Physical card not working despite being usable online


#1

I’ve just gone to my local cash machine and can’t withdraw money, I then tried the store it’s at and it’s not working in there either. I then tried to buy something online as a test and it worked. I got paid yesterday so there is definitely money in the account.

This is a major issue, I’m by myself on the other side of the world without access to my money which means I can’t afford to get to work or even buy food. I sent a message to the online support an hour ago and haven’t heard back.


#2

Is there anything disabled under Cards > Security? You can also reach support on Twitter (@RevolutApp) and on Facebook: https://facebook.com/revolutapp :slight_smile:


#3

Nothing is disabled. I’ve toggled it on and off and will try again. I’ve messaged on twitter and will try Facebook now


#4

First of all, as @c0stin already said but just to be sure, I’d go to “Card Security” in the app and make sure everything there is disabled (also “Location-based security”). Then, I’d also make sure there is no limit set for your card.

Is there any record of the failed transactions in the app? Note that this would appear under your main currency (GBP if you were UK-based at the time of creating your account or EUR otherwise), even if your balance is all in USD.

Have you tried another ATM? Some ATMs never seem to work with Revolut, although it’s rare. Also, some classes of merchants (petrol stations) are entirely banned. In the latter situation, there would be a message saying “Merchant is not supported” for the attempted transaction.

In some countries (Japan), most ATMs only accept local cards, although they confusingly have Visa/MC logos on them. Could this be your situation?

In a shop if the contactless payment doesn’t go through you can ask them to try again with the chip, or vice versa.