Upgraded app can't access my account anymore


#1

I have recently upgraded revolut app on my phone, and it asked to create a new account!

I did it, with the same email, etc and now I can’t access my funds, I only have access to this new account!

Has anyone else had this problem? Is revolut a money trap?


#2

Hey @Fccoelho :slight_smile:

No money trap. Your account “ID” is your phone number. Therefore, if your phone number is different, you’re making a new account.

You can probably get someone from :r: to fix this for your clicking Support in the More tab of the app :wink:


#3

But even so, it shouldn’t be so easy to obliterate an account. Just because
you are traveling and decide to upgrade the app.
The upgrading routine should detect that there is an account already
configured and validated and warn the user before doing anything.

I got feedback from the support. I hope it gets sorted.


#4

Revolut did not obliterate the account. :slight_smile: It only happened that your app could not log in to it.


#5

Hello,

I have the same issue. Is there any other way to contact Revolut?
I am having trouble getting an answer on the live chat.
I realised with new number that a new account was created.
I need to access my ‘previous’ account urgently.

Thank you!

Noemie


#6

I solved it through the live chat. They’ve reset the phone number on my
account.
Keep trying.


#7

Thank you! It worked :slight_smile: