Update 6̶̶.̶̶1̶̶3̶̶ ̶̶6̶̶.̶̶1̶̶4̶̶ ̶̶6̶̶.̶̶1̶̶5̶ 6.16 for iOS


why is the :r: app asking twice for touch id? To reproduce:

  • Make sure that the app is closed
  • Open the app and authenticate with touch id
  • Press home button
  • Wait a while
  • Open the app again and authenticate with touch id

Now the app asks again for touch id to unlock the app. If I click “Cancel” I can use the app anyway. Is this a bug?


In my case, it lets me open the app without prompting for Face ID, which is a massive security issue. Whether this is on :r:'s side or Apple’s, I cannot say.

Up until now, I was prompted for Face ID as soon as I left the app, regardless for how long. I haven’t seen (but I might have missed it) any setting like “don’t prompt for Face ID for n minutes”.

1 Like

Hi, I don’t face this issue in my iPhone. Did you check your settings to if “Sign with Face ID” is on??

It has been working fine until earlier today. iOS 13.1.3 and app version 6.13.I will give a reboot later today and check again. Thanks for the assistance.

You are welcome. I updated to 13.1.3 yesterday. Seems to be working fine so far.

If this option is off they app should ask for your PIN, I guess. So something is wrong nonetheless.

You are right. Either PIN or Face ID is to be entered while opening the app

Yep. Have the same bug and wanted to post about is as well.

iOS 13.1.3 and Revolut 6.13 with an iPhone SE.

This bugs is still not solved even updating to Revolut 6.14 on iOS 13.1. Please fix that, this is making me mad.

1 Like

This is kind of odd bug. I don’t see it in my iPhone and neither my spouse on Android phone.

Do you have an iPhone with Touch ID or Face ID?

My iphone has Face ID

You may have noticed that the described bug from the first post is happening with Touch ID.

Pro tip: secure your phone with Face ID.

It is already. I cannot use Face ID in an app if it’s not set system wise

I see that. That’s why I mentioned that my spouse phone which uses TOUCH ID doesn’t have any issue😉

Your spouse uses an Android phone. Touch ID is only available on Apple devices. :wink:

Thanks for your link. I believe Apple calls it Touch ID while Android phones call Fingerprint technology:wink:

Yep. Even though both function with the finger, the underlying technology is differently implemented. That’s why you can not compare the bugs from different devices.

Fingerprint unlocking on an Android device ≠ Touch ID on Apple device

1 Like

You are absolutely right that Touch ID is used by Apple devices and Android uses a different technology. This is similar to the difference between Apple Pay and Google Pay. I totally get what you are trying to explain.

But from an app developer point of view, both are nothing but a method of unlocking the phone or opening an app by using one’s fingerprint instead of a password authentication, without going further into a nitty-gritty of coding difference between iOS and android apps.