Unable to upload cash

I am unable to upload cash via my usual card. It says pending and then just fails after about an hour.

If I use Apple Pay to upload using the same underlying card it works.

Support chat is down.

Anybody having similar issues?

I don’t know if Apple Pay works this way, but maybe your bank is allowing Apple Pay to charge you but not Revolut. Have you tried contacting your bank?

Top-up, open your bank’s app, approve the transaction, voilà!

Never had to approve the transaction in all the years I’ve been using Revolut.

I’ll call the bank. Maybe they’ve blocked Revolut for some reason.

Most likely it’s 3D Secure. New regulations bring it into play. https://en.wikipedia.org/wiki/3-D_Secure

Let’s see what your bank says.


Revolut says the upload failed because of 3DS. I have about 20 failed uploads since yesterday.

I’ve written to my bank (Santander) to see what the problem is.

Same card has worked for years uploading to Revolut and it still works now uploading via Apple Pay.

Some times with many failed attempts the bank blocks the same transaction, Just call them an make sure everything is okay from their side.

3DS does not exist forever. It came to play “lately.” This is why you – I bet on it – would have had to switch apps and approve the transaction. I’ve seen that issue before. It’s the same process as in e.g. a webshop.

Google Pay and Apple Pay are surely treated differently because you steadily prove that it is you’re device via fingerprint, face rec or PIN.

1 Like

Now it works and I’ve done nothing to fix it.

1 Like

Hello, I have the same issue, I called my bank and they are not blocking Revolut and they can’t see any reason for it being declined.
Does anyone have any idea how to fix it please??

Mine fixed itself after about 2 days. No idea what caused it to fail.

Revolut was having issues with top-ups, there was a warning message on the app.

I have the following issue, opened the App today, and tried to add funds to my account, but there was no card associated with my account, there was up to last week as i lodged funds and made a payment, but today the same card details were missing, so I went to input the card details and validate, it seems to be spinning at the verification stage, so I cant add funds to my account.
anyone else have this issue ?