Unable to open Revolut Account

Hi Team,

I have registered to Revolut using my UK mobile number but unable to proceed further as it continuously says “Awesome! You took the first step to open your account”. I haven’t received any email and it’s been few weeks already.

2 Likes

Hi @t007basu and welcome to our Community :wave:

Which country have you selected upon registration?

Thank you!

Mariana Rodrigues I Community Manager

1 Like

Hi @Mariana_Rodrigues

I have selected UK (United Kingdom) as the country. Please let me know on the next steps to complete the account registration.

Thanks
Tanmoy

1 Like

Is there any update on this? My partner tried opening her account and it got created instantly. Why mine isn’t working ?

1 Like

Hello @t007basu :wave: ,

Please attempt to log in to your account and finish the registration process in order to activate your account. :hugs:

SG | Community Team

Hi @SG.Mandal
Yes, I have tried but as soon as I login with my mobile number or email, I get the attached screen. I haven’t received any further email from Revolut.

1 Like

@t007basu, Sorry to hear about the error message you’re getting right now. Have you tried the following troubleshooting steps? :arrow_double_down:

  1. Make sure your Revolut app is updated to the latest version available
  2. Clear the device’s cache:

iPhone: ‘Settings’ → ‌’General’ → iPhone storage → search for the Revolut app → select ‘Offload app/clear cache’

Android: ‘Settings’ → ‘Apps’ → search for the Revolut app → click on the app → tap ‘Storage’ → clear cache

  1. Close the app (close it completely from the app switcher)
  2. Turn your device on and off
  3. Try with both Wi-Fi and mobile data — ensuring that network connections are strong and stable
  4. If none of this helps, use an alternative device (if possible)

After finishing these steps , please try to log in again and let us know if you face the same problem. :pray:

SG | Community Team