Unable to access app

I struggle with the same please let me know if you find a solution

I am having the same problem! Cant access my account, says wrong password. Then trying to reinstall it, it just wont let me pass the text message code. Help please, it is really frustrating that I cant use my card…

I’m having the same problem - can anyone help?

Having this same issue at the moment.
I can’t reach support in anyway other than here, and even now, all I can do is reply to this topic - I can’t create my own to discuss my own issues.
Seriously what is happening with service - genuinely regretting upgrading to Metal at this point.
The service has took a serious dive over the last 6 months.

How can I get back in to my account if you don’t ever send a number or call?

Please help!

Hi all,

I am new on here and I am unable access my account and what to see how did any of you manage to resolve it. I am suddenly being asked to provide my source of income and it keeps searching for live agent for the past week and over so I can talk to them but so far no one is responding to me. Please is anyone able to help me. I really need my account back. My brother’s and my mum is also facing the same issue, which is very strange. Thank you in advance.

1 Like

I have the same problem myself, I have changed my phone number and the original one (UK) I have left as I moved to Mexico. I cannot log in anymore and I do not know what to do.

Same issue, what’s the fix? Can’t access the app to do in chat as can’t logon! Very frustrating as you can’t speak to an actual real human being!

1 Like

Anyhows, i have no access to the app with any of my old numbers, cant create a new account, and have a completely new number and no access to the old numbers except one, but it is not the last one used. Have access to the email everything is registered to. Really hope to get a reply soon preferably via email! Wish you an amazing evening!

Kindest regards,
Dmitriy V.

Hello!

I have registered a new passcode to the number last used as a new account, and can’t access my account hence via the second lost number option. Or I possibly don’t remember the number correctly. Either way I have no access to my account, and can’t register a new one. Could anyone from support please contact me via email registered here in the community? Wish you an amazing evening!

I tried to make a transfer from my account. The transfer kept failing. the in-app support told me to log out and log back in. When I try to log back in after putting in the correct mobile number and passcode I get the message ‘something is wring try again later’. So I cannot access my money and there is no customer support. Any ideas out there. This bank must be regulated by the FCA so how are they able to stop people accessing their own bank account?

I have not changed my phone number yet now when i try and log into the app I get asked for my phone number then to input a passcode and my personal details. It recognises that there is already an account with similar details. What can i do, the fact that you can’t access support without logging in is outrageous, what good is support if you can’t use it when you have an issue?

I add « Face ID » only iPhone and now it’s OK

I was able to get it sorted. Apparently what happened is that the first time I tried to log in to the new device, I somehow created a new account. When you have 2 accounts, it causes some issue, and I was stuck in this endless loop of not being able to log in. - I emailed feedback[at]revolut.com in order to get assistance. This seemed to work, although response times are slow, the team was very friendly and helpful. Good luck!!!

Hello @AndreasK and @JessicaZ

I hope all is well. I have a technical issue.

I just upgraded the Revolut app to 6.32.1 on my iOS 13.3.1, but I cannot log in anymore. After the upgrade, the app asked me to key my phone number (which I did correctly), then key in my pin (which I did correctly), then click on “Go to inbox”. However, when the Gmail app (version 6.0.200244) launched, it showed the error “Failed to open link - Unable to understand the link”.

I am unable to even log into the app; thus unable to use the in-app chat function. Please advise.

I am a fan of Revolut and had planned to increase my spending with the Revolut card. Your help will be greatly appreciated. Thank you!

Cheers

Hi @AndreasK and @JessicaZ

I hope all is well.

I’d like to request your help for a technical issue.

Two days ago I updated Revolut app to 6.34.1 on my iOS 13.3.1.
Awkwardly it requested passcode, not touchID as usual.
Selected “Forgot code” option. Received an email with link to open in Revolut App. At this stage it requested my Revolut card original PIN. I do not have PIN noted anywhere because it was secure inside app.
Now I’m unable to log in.

How could you help me solve this?

Thanks in advance.

Kind regards.

Hello
I have same issue. Passcode doesn’t work and can’t access the app to chat with the support. I have always been a fun of Revolut but this time I see the limitations of the system! No idea how I can get access to my account!

I have the same problem can somebody help??

Hi Everyone, am currently experiencing a similar issue.

After updating the app, I tried to log in to update my ID. Originally it asked me to enter my phone number, and then ‘create passcode’ which was strange because I already had a passcode. It was then asking me to enter a verification code I was sent, which when entered took me right back to the first page of ‘enter phone number’, looping me back through the whole process again.

Same story on my iPad. Have uninstalled and redownloaded the app hoping this will help. Now it asks me to ‘enter phone number’, then ‘create a passcode’ and comes up with ‘something went wrong, please try again later’ message. It has been several days now with no change.

Cannot contact support because I can’t access the app. No online log in either, nor customer service support accessible via phone.

Has anyone found a solution?

I’m having the exact same problem. Has anyone been able to help?

My friend has the same problem. Is there anyone here that might help? Please