Top up with Transferwise Debit Card suddenly failing.


Hi there,

I have a Transferwise Debit Card which I’ve used twice before to top up my Revolut Card with no problems.

Today, I tried again and the payment failed, telling me the address I’d entered in Revolut for the card doesn’t match what I have registered in Transferwise.

I’ve double checked and it does - I’ve also re-entered my address in Revolut, but the top up still fails.

Any idea why it’s telling me the addresses don’t match when they do. And any idea why it worked before, but not now?

cc. @AndreasK

topup via TransferWise

Any strange characters or spaces, points, commas…in your adresse?


Hey Andrew. You have managed to top up your account :slight_smile: Please don’t hesitate to contact us if you have any further questions.

Have a great day.


Andreas K


Thanks for getting back to me @AndreasK - I had to use another card to top up my account in the end. But I want to know why the topup with the Transferwise Debit Card failed when I used the correct address and when it’s worked 2 times before?



Can you reach me via a direct message?


Will do @AndreasK - thanks for the help.


@dunxd - Are you still able to top up Revolut with your Transferwise Debit Card like you mentioned doing before? I’m trying to see if this is just happening with me, or everyone.



I topped up successfully this week. Note that TransferWise has transaction limits on their card - monthly limits and 24 hour limits - for different kinds of transaction as well as overall limits for all card transactions. These can be changed. When TransferWise rejects a transaction it tells you why in the detail for that transaction.

Revolut also has a annual limit of 25k top up unless you verify your income.

Check if you’ve breached any limits.


@dunxd - Thanks for the reply. Glad to hear it’s working for you. I’ve checked and it’s not a limits issue, I’m way under on Revolut and Transferwise (even testing with 10 Euros top was declined).

I spoke to Transferwise support - they’ve told me there system isn’t giving them any more information for the decline reason and suggested I refer the issue to Revolut seeing as I’d topped up before successfully and nothing has changed their end.

On Revolut, the error is gives me is “the address you’ve given us doesn’t match the billing address you have registered with your bank for this card” (or something similar) - except I’ve double checked and it does, and it wasn’t a problem when I topped up twice, two weeks ago.

@AndreasK suggested deleting and re-adding the card, but now it won’t even let me re-add the card due to the address error. He also suggested Apple/Android Pay, but I’m languishing on an old iPhone, so can’t try that yet.

So for I think I’ll give up and try again later.

Thanks for the help everyone :slight_smile:


any update on this case?
exactly the same problem, chatted with transferwise and revolut support and nobody can solve the case… also removed the card and now i can‘t even add the card anymore :confused:


I believe it’s an issue with the Address Verification System:

I’ve not heard from @AndreasK recently, so I don’t think this is resolved yet.


I too have been having this problem topping up from a transferwise account. It worked fine to Monese, but not Revolut. Same address problem.


Is this issue solved now? (I am asking those who have TW card).


My TW card was issued in June '18 and I didn’t have any problem


I have the same problem currently. I will let you know if it will be solved by TW support. Revolut support said that I need to confirm with TW if my address in AVS match those which I entered in TW account. It was the same but written with some shortcut. I changed it but maybe it needs some time to propagate to AVS. I am waiting for live chat availability on TW site.


Ok. Problem solved. The address assigned with TW card was shipment address which was different than I use in TW and Revolut accounts. I asked TW support to align this address with the one I use in account settings. After this alignment top up with TW card works without problems.