Top-up refused since June update


#1

In the end of June, with the revolut app upgrade, I have been asked to register my (French) credit card again since the top-up method had changed and was more secured. Since then, I have registered my card by I have not been able to top-up with that card since the bank is forbidding it when I want to do so.
Is it possible to come back to the previous top-up system or at least, to be able to choose it ? Another solution could be to be able to top-up without registering the credit card.

Edit: The problem have been solved for me since the mid-september update. A 3d-secure confirmation is now asked at each top-up


#2

I have the same problem with my bank. It’s frustrating. I tried to contact my bank and revolut, but still no way to fix it


#3

Same here for a French VPay (systematic authorization). Otherwise my VISA (classic/debit) works well.


#4

Same issue here, with a French Société Générale Visa card


#5

Same bank but doesn’t work only for the VPay one.


#6

@julien, @Albertas, @dawol, @pvk Are you all Android users?


#7

iOS 9.3/10b7 here! :raised_hand:


#8

@andreas.kapsos iOS 9.3.4


#9

I am a iOS user. :r:


#10

Same here !
The app crashs everytime I finished to add my Sogé debit card :cry:


#11

I got the message “The card can’t be approved” after a successful 3D Secure verification here.


#12

iOS 9.3.4. This problem accure with some banks.


#13

Same here with Android 6.0 and Visa Premier (AXA Banque).

The whole Revolut service has become totally useless for me since mid July.

The problem is not with AXA. They do send the security code over SMS, but the Revolut App gets stuck and unresponsive and never displays the screen to enter the code sent by the bank.
Revolut support advised me to delete the card that was already registered and to create it from scratch, but this only made things worse, since the addition of a new card does not work either.
Support (in app chat) recognized this is a bug, keep saying they are working on this and that a fix should be available ‘next week’ (that’s now over 5 weeks that ‘next week’ is a moving target!).
I was particularly disappointed that a new version of Revolut App for Android was released without the fix.


#14

Same here on Android with SG.


#15

In fact this problem is due to Revolut’s new payment processor since July that seems reject the VPay cards while the old one was accepting it with no problem at all. :confused:

from now I moved to a Classic VISA card and it works perfectly


#16

I have a Classic Visa Premier card.
It does not work.


#17

Oh. Weird. Mine works well.


#19

I have just re-tryed and it seems to be fine now. \o/


#20

Hi

There was an issue with the French cards and the android version, which it has been resolved.

@phl38 can you please send me a direct message with your phone number so I can take a look?


#21

Hi,

The problem have been solved for me on iOS in the last update.
Thanks for your work !