Top UP not working for Mastercard

Mastercard not working or at least for Unicredit Hungary ,Czech Republic and others not working.
Gives a string error after Mastercard Id check
The support said they are working on it but no fix yet

2 Likes

MasterCard from Raiffeisen Bulgaria also doesn’t work. The bank says that the problem is in the Revolut POS terminal (or something like that)

It worked on my side now

1 Like

Top ups work on an amount of 100 euro per day for Mastercard in Hungary if you top up 30 Eur at a time but there is a limit per day imposed which is from Revolut side.
Before the limits were imposed the daily limit of the bank card was the only limit.

Not working for me here in Italy either
After completing the Mastercard ID security succesfully, it then shows a white error screen as though something has crashed.
Most annoying as it is the only method of topup that I use.

1 Like

Have you tried to top up 25 euro x3 times?
Every month there is a feature that Revolut has decided to take away with no heads up no email no push notifications
Totally unprofessional behavior

Italian here and same error happens.
I came to the forum just to see if others were reporting this, and I’m happy to see I’m not the only one. I contacted Revolut support and they said it’s a problem with the 3D secure verification on the issuing bank’s side. But I doubt that, since it happens with more than one bank.
Actually, it’s been like that since one month. I thought it was temporarily but as of today it’s still happening.

Please make something about it. :no_mouth:

1 Like

same for me, I can’t top up for a week now with a hungarian Unicredit-issued Mastercard. tried with multiple amounts, but no luck. the transactions can’t even be seen in my Unicredit card history as if they weren’t ever started.

This is the error screen I see after completing mastercard security screen. Is anybody else getting the same error?

We are all getting the same error.Dont have any hopes from Revolut that they will fix it because as mentioned above their response is use another card.So use Transferwise and forget Revolut.

@Revolut_User Same thing happens for me, exact same error. I have contacted both Unicredit HU and Revolut support regarding this, they all say they are aware of the issue and “working” on it. But experience shows that they are not so keen to resolve it soon. If they had real intention to do it, they would have done that already. Such famous and big companies that they cannot work it out together, it is just frustrating. I will probably cancel my Revolut premium subscription if this will not be resolved in next couple of weeks.

Still no improvements, not always the same error, sometimes server isn’t reachable, but at the end of the day, we cannot top up Revolut account using UniCredit Hungary Mastercard.

Same here :confused:
Android app, ver. 7.29.1
UniCredit Bank, I tried both Visa and Mastercard cards

Same here! Visa card by UniCredit bank Czech Republic. The same error massage that guys posting in the thread above after I enter 3ds code. Cannot top up my account for three weeks. Talking to Revolut support but with no result. Very frustrating experience

The solution posted already is that you can use transferwise app to top up then if you want you can convert and transfer to Revolut .Probably that is why Transferwise lowered the fees 15% for the coming months to get more clients from Revolut.

2 Likes

Another solution (based on answer from Revolut support, I haven’t tried it) is to add card to Google Pay and to make topup, since they are not affected with the issue.

Right, I confirm that with google pay and italian unicredit card everything is fine. With the card directly it doesn’t work anymore (in november it was fine).
In december I have also the same problem with my other credit card (master card of ING)…it was fine in november but now it’s not working anymore… really bad.

Advice for me was to do the topup using ApplePay first, then usual method which all of us are missing. Yes, but if I would be able to add MasterCard to Apple Pay.

now they tell me it is my bank’s issue, but i can use my card to top up different account, so I highly doubt. And from today I cannot use my Revolut cards either to top up other accounts. This is getting very strange…

Hello all, good news. I managed to do the topup this afternoon using MasterCard from UniCredit Hungary. It didn’t ask me for any authorization, just processed and voila, it passed. Maybe they disabled that 3D secure authorization. Didn’t check if it works second time too, because I reached my limit, but at least some improvement.

2 Likes