Top-up JPY with JPY debit card not supported, plus many more!


#1

My JPY debit card always works for GBP, EUR, USD top ups. After 6 hours on the app chat with Maciej, too much back and forth between lunch and meetings etc…

According to support chat Maciej, the following currencies are NOT supported for top-ups via debit bank card yet - AED, CAD, HUF, INR, JPY, MAD, MXN, QAR, THB.

Also, the error message you receive when you do top-up with the above none supported currencies is too vague “We’re sorry, something has gone wrong. Please try later.

Not sure why, only been told “the issue is being investigated”. However the error message should say it is not supported.


#2

Hi Ben,

We’re sorry for the inconvenience caused. I’ve just had a look on your account and it appears there are no recent top up attempts. Can you please try to top up again and let me know if the issue persists?

Thanks,
Rob


#3

Hi Bob,

I have tried with card 8054 several time and just 3 mins ago, same error, “We’re sorry, something has gone wrong. Please try later.”

Kind regards,

Ben


#4

Please keep on updating on this issue. I’m interested in this too…


#5

Hello, I’m getting the same issue, and I was able to use my Thai card before to top up. Now I can’t add new card.


#6

Just had a quick update from the tech team - they’ve figured out what the issue is and are now fixing it. It shouldn’t be too long now but I’ll keep you posted here.


#7

Thank you for your answer, waiting for your soon update! continue the good job :slight_smile:


#8

This issue has now been fixed! Please download the latest version of the app (v4.5.9)


#9

For iOS and Android?


#10

I don’t see any update for Android can you ask the dev team to fix Android version? As I still get the same error on Android.

I will try from my iPhone but my main phone is an Android


#11

There is a bug!
I’ve tried to add my card on iOS version of the App (4.5.9), and I get an error:
"Card expiry date is in the past. Please, use a different card"
But I’ve submitted the correct one, and the year is 2021

Can you check?


#12

From the tech team - Topups by card are only supported in the following currencies:
GBP, EUR, USD, PLN, CHF, DKK, NOK, SEK, RON

@Masterchef , we will look into your issue but if it persists, please contact us via chat.


#13

How come was it possible to add a previous card before now?


#14

We will be in touch via DM to help you with your issue.


#15

Rob, thanks for the quick turn around. It is clear now which currencies are supported for topups.

Kind regards,

Ben


#16

What I’ve understood about this, it’s:
We should be able to add whatever kind of card from whatever countries, but the only currencies we can use to Top up are:
GBP, EUR, USD, PLN, CHF, DKK, NOK, SEK, RON
That means, for myself, I should be able to add my Thai card, and Top Up using one of the currencies above.
I was able to add my Thai card before, but I’ve changed it, so I was in need to update my cards list with my new one, and then I get the same issue as you @BenG, they are actually working on the bug fix. I will be updated soon (I Hope) when it will be fixed. And I think, @Rob_B will update this thread when he will get good news :slight_smile:

I love Revolut’s customer service! Keep the work!


#17

@Masterchef allow me to clarify:

You can currently top up via Bank Transfer in the following 25 currencies:
USD, GBP, EUR, PLN, CHF, DKK, NOK, SEK, RON, SGD, HKD, AUD, NZD, TRY, ILS, ZAR, AED, CAD, HUF, INR, JPY, MAD, MXN, QAR, THB

Of these currencies, only 9 currencies can be used to top up via Card:
USD, EUR, GBP, PLN, CHF, DKK, SEK, NOK, RON

The error @BenG mentioned was an internal error which has now been fixed. In short, the bug pre set the wallet (showed the JPY option) although it is not in the Card top up currency list. The development team has confirmed that the issue has now been dealt with and top ups are fully working again.


#18

@Rob_B Thanks so much for the clear follow-up. It is very understandable now.


#19

I still get the same issue about: Card expiry date is in the past.
From iPhone


#20

I’ve just tried from my Android, and still get the error:
“We’re sorry, something has gone wrong. Please try later”