Top Up Fails due to missing 3DS

Hi

Recently, all top-ups from Revolut fails, with reason: “3D-Secure Authentication Required (20154)”, the issue being, I don’t get an option to go through the 2FA check.

I contacted support, who suggested reinstalling the App. This allowed me to do one top-up, since the 3DS prompt came and allowed me to continue. When I then try to initiate manual top-ups, it goes straight to fail.

The support agent suggested I should contact by Bank, claiming this is an issue with my Card. They declined, saying Revolut is supposed to prompt for the 3DS, which seems to match the error code I see in Revolut.

If I delete the card from Revolut, it also allows me to do 1 top-up (with 3DS validation) before it breaks again.

The issue seems to have started together with the new EU regulations about 3DS.

I live in Denmark, and is using a card issued by a Danish authority.

I have confirmed with several of my colleagues, who has the exact same issue.

1 Like

Have the exact same issue. Same country.
Can only top up from website, not from the app. It doesn’t redirect to 3DS validation site.

The 3DS redirection happens at the issuer and not at Revolut.

It would be valuable information to know which bank you use - since 3DS is prompted by the issuing bank and not by Revolut. 3DS issues can happen in many places: Revolut, issuer (bank), processor, and clearing.

3DS in Denmark is managed by NETS, and they are absolute amateurs. Probably this stems from yet another 3DS issue at NETS. Before Christmas, all payments were declined where I work for 3 days until they did something about it.

And no, NETS does not update their system status. As in ever.

I feel that it could also be related to the type of 3DS verification Revolut requests: Single-use or permanent verification (used for subscription payments and to store card details for later transactions).

I’m with Sydbank, and so is everyone else I know having issues too. Could be. I’ll try contact them again, see if they could figure something more out.

Same issue with Nykredit - also Denmark

I can’t top up and I can’t even transfer money. The 3ds pops up, but the transaction fails nevertheless. The transfer is denied by the service provider. (Hungary, Budapest Bank)

Same problem here. Denmark, Jyske Bank.

Same problem, Denmark, Danske Bank

EDIT: I removed my Danske Bank Mastercard and re-added the card. Top-up no longer works more than once.

Same issue here, Denmark, with both Arbejdernes Landsbank (Dankort) and Norwegian Bank (VISA).

No problem with Curve as payment card
And Lunar bank underlaying card https://lunar.app/dk/

I just tried with 100kr. It worked fine…

The issue now seems to have been partially solved.

At least for manual top ups, I’m now getting the 3ds verification prompt.

There seems to be a thing with amounts as well. 200 and below goes straight through, 201 and above requires 3ds.

Same issue here, Denmark. My wife has Danske Bank and I have Lån & Spar Bank. Fail to top up.

I have the same issue as well, I have Danske Bank.
Have tried the solutions mentioned above with the same results.

I have the same problem; do we can resolve??

My Danske Bank Mastercard works again for smaller amounts, also repeat attempts - but it failed once I tried with 500 kr. with the usual “3D Secure error”.

Still doesnt Work for me. Earlier today it suddenly worked manually with 200. But now its broke again.

What is 3D-Secure Authentication and how do I get it?
I’m a new user and I tried to fund my R account from my bank. The amount appeared, but then disappeared as I wanted to exchange USD to DKK.
Now after hours of attempts, I managed to get the amounts to appear again and I set up limit orders for the exchange. I now wonder if I will have problems when I try to transfer the DKK to my Danish bank if I don’t have the 3D-Secure Authentication?
Can anyone guide me?

3DS is simply the two factor that happens when you try to use your card online.

In Denmark, this is often our Nem Id.

It shouldn’t be necessary to use 3ds when transferring money from revolut account to a bank account. Only when using your cards. Remember, the bank transfers can take a few days to clear.

But I think that discussion is a little off topic for this thread. Id recommend you start another yourself.

The part of, your money not coming into revolut from your US may be relevent tho, if you’re adding the money via card.

If you open your transactions list, find the declined transaction, and open it. Then download the confirmation. In there, it should give a reason why it failed.