Top-up 3D secure Visa Eletron Error - Portugal

When i try to top up with my visa eletron debit card, using 3D secure in Portugal, is always declined.
Would like to solve it please

1 Like

What bank are you using? I’ve been using ActivoBank and everything’s great.

Hey! Have you tried to get in touch with our in-app support team?

I’m using activobank either…

No, i didn’t ask help to the support team. I was hoping writing here would help me…

Make secure you have 3D Secure activated. Are you receiving the text with code on your phone? Is the Millenium BCP dialog appearing on the app for you to put the code? If so, I don’t know why it could be failing…

Yes, i have active. I receive the text and input it the the MilleniumBCP dialog windows that opens…
Maybe someone from the support team will contact me to try to solve it.

1 Like

Hi diogo,

Yesterday I used by CTT bank and received the text with code in my mobile phone. Without any problem.
Maybe you dont have the 3d secure actived or your mobile phone number is not actulized. Better to check in your bank your personal data.

Problem keeps going…
Trying to topup with web card from activobank (PT) and dont even received the 3DS message, it says insufficient funds…
Any help?

Same problem here… Visa Electron BPI.

I have 3D secure active, got the code from the bank, insert the right code and got the “We’re really sorry, but you need to activate 3DS authentication through your bank” from the Revolut app.

Contacted the support team and got told that everything was OK from their part, it was the bank that had a problem. Contacted my bank and got told that everything was OK from their part and it was the “site” that was declining the transaction…
How can this be solved?

It seems like revolut is incompatible with BPI’s 3ds method. Probably BPI is trying some weird redirect for you to insert the confirmation code and Revolut just gives up waiting for the confirmation.

If I were to blame someone would be BPI’S as they’re probably using an outdated 3ds verification method

Wouldn’t creating a virtual credit card with MB Way solve this issue? I know it’s not the real solution to this problem but it’s a workaround. I’ve topped up my card with ActivoBank using 3D Secure and I had no issues. I think it won’t ask for 3D Secure if you guys use MB Way, but I’m not sure.

I used the Boost card from ActivoeBank by the way. Lately I’ve only been using virtual credit cards from MB Way with no issues whatsoever.

Just had trouble topping up with a CGD card, but I was able to at the third try, so it seems the issue is with revolut

After entering the 3ds number received by sms, the app is supposed to close that Web window and show the top up confirmation screen, however it gets stuck with the Web window open and if you close it manually the top up fails

Maybe the virtual cards won’t ask for 3ds, honestly I don’t remember if the do

Same problem here. Occured only today for cgd it was Really weird since i had topped up 4 days ago and everything was fine. Today i needed to top up a bit of money in denmark and it wasn’t working.
I was getting the 3d secure error and tried to remove the permissions in my bank and add them again, but had the same result.
Hopefully it’s just a temporary problem since it’s gdpr day

I have the same issue since yesterday and right now, also with Millennium. Already after entering the 3D secure code in the Millennium’s window you are usually quickly shown a blank white screen with “Verification” at the top. But now it was stuck there for 5 minutes and finished with “your top-up failed”. I had the same problem about half a year ago, I think in May. But then it disappeared.

Maybe the problem is what is described here:

Or Millennium runs some additional security and blocks “suspicious” transactions. (Would be very strange to do it after the 3D security.) Last time I had this issue it was at the very beginning of using Revolut. Now I had to top up by a large sum to order furniture in new apartment. I guess in some situation that could look suspicious.

Update: and it worked just now! Not sure what magic happened, maybe Revolut did some or just the stars moved in the right places. Now the “Verification” page also showed the spinning process icon and finished well. I think when it got stuck nothing was spinning.