"This Action is Forbidden" Error - Business Account Information

Hi all, I am trying to apply for the Business account and while on the “verify your identity” screen after pressing “Continue”, there’s an error of “This action is forbidden”. I have tried it multiple time over still seeing this error. I tried to reach out to help but can’t manage to get to the chat…

Any idea how to solve this? Thanks

2 Likes

Hi @fifteen and welcome to our Community :wave:

Sorry to hear about your trouble. Have you checked if your Business type is supported by Revolut? :thinking:

Revolut Business account is available for the majority of legal types of business, although there are some exceptions, such as charities, public sector companies, cooperatives and more. If unclear on whether we support your company, please reach out to our support via chat.

Revolut Business is available for the following types of business:

  • Private Limited Company
  • Public Limited Company
  • Limited Liability Partnership
  • Limited Partnership
  • Partnership

Unfortunately we can’t activate Revolut Business accounts for the following business types:

  • Public sector
  • Charity
  • Private foundation or trust
  • Cooperative
  • Freelancer or soletrader
  • Other

Any other businesses types, at Revolut’s discretion - see “Not supported industries" for more information.

Hope this helps!

Mariana Rodrigues I Community Manager

1 Like

Hi Mariana,

Thank you for getting back to me! It wasn’t because of the Business Types as it is one of those supported ones.

The error appears when I am verifying Director’s information under Company Structure.

I have tried starting a chat as well but it seems to have submitted a ticket without followup?

Thanks.

2 Likes

If you click on the chat icon, does it appear your previous query? :eyes:

1 Like

Not sure if I missed something but when I click open your chat link above I see this:

So it does not have chat button nor anything I can do to create new chat.

1 Like

Thank you for sharing the picture with us @fifteen. May I know have you clicked on “I haven’t - continue to next step” button? :thinking:

SG | Community Team

1 Like