Third-party keyboards in iOS


Since the stock iOS keyboard is a sorry, disgusting piece of trash, I’m using a third-party one, namely SwiftKey. However, whenever I have to type something in the Revolut app, be it a note attached to a transaction, or a message to a friend, or a chat with the Revolut support team, you name it, it always forces the stock keyboard to pop up and doesn’t allow me to switch to my normal one.
I can see the need for blocking third-party keyboards whenever sensitive data is being typed, e.g. in password fields. But this isn’t the case here. I’m not typing anything private or classified.
It would be great if the app worked with whatever keyboard happened to be set as default and not try to impose the stock one all the time.

Thank you.

I am not an iOS expert but as fast as I know, you cannot block 3rd party keyboard on selected screens of an app. So it’s either allowed or not.

To be honest though, I don’t think :r: will allow them any time soon. 3rd party keyboards are a very serious security risk that a lot of banks block them.

Sure they are, when you type sensitive things, like passwords or account numbers. But in the notes? Or in a chat? Come on, what security risk?

The only way to get help from Revolut is via chat. A chat which only works in a mobile phone app. So you have no other option but to struggle to type a lot of words on a tiny little touch screen. Then, as if this weren’t enough of a chore, it won’t even let you use a proper keyboard, but instead forces you to use that hideous, horrendous piece of shit that in Apple’s mind passes for one.

When I add notes to transactions, I add them in my native language. So I need to use diacritics. But the app only uses the English iOS keyboard (even if different languages are installed, too), which doesn’t have the ones that I need.

OK, so Microsoft could theoretically find out what label or explanation I’ve attached to a transaction. Who cares? I don’t.

You also can chat via web browser after logging in.

1 Like

Are you sure about that? I can choose different language keyboards in the app. Or does that change when you go into a chat?

You’re right. I tried again and it worked. My mistake.

No worries, always trying to help. :slightly_smiling_face: