Statements in Excel - CSV format errors


#1

When exporting transactions to Excel the .CSV format is used. The comma is used as separator. However the comma is also used as a delimiter for the thousands. As a result importing transactions or balances larger than one thousand messes things up.

Example:
03 May 2017 , Exchange to EUR , , €15.71 , , , 1, 298.05, general

Because of the comma “1,298.05” is interpreted as two separate values “1” and “298.05” in stead of the value “1298.05”.

You might remove the comma as delimiter for thousands when exporting to CSV. Thanks!


#2

Just came across this too. The date is also not idea as it needs a special date format to be selected in order to be converted. This makes is ver tedious to export the data to budgeting apps such as YNAB. Another option would be to suply the data in a standard .qif or Microsoft money format.


#3

Someone at Revolut needs to take a read through the specification for CSV. For the UK, field separator is supposed to be comma.

The issue with thousands separators, decimal points/commas and all that HAS been taken care of in the spec.

Pleas get rid of the semicolon separators in CSV for the UK! Excel won’t import properly when set up for UK/US without manual intervention.