[SOLVED] Verification Process Stuck ?


#1

Hi,
I have a problem with the verification process. I’m waiting now for almost 48 hours, but nothing seems to happen.
I have already sent the documents that needed and I still waiting.
I have already sent a message in chat from yesterday but to no avail.
I tried to log out and log in back, but that didn’t help also.

Please review the documents. Don’t keep the customers without feedback. It’s not good for business.

Best Regards.


#2

It usually means that one of the pictures of the documents isn’t readable and cannot get verified. You have to talk to support :slight_smile: They can also be reached on Twitter (@RevolutApp) or on Facebook: https://facebook.com/revolutapp


#3

Thanks for the reply @c0stin.
I know about the unreadable state in Verification. It’s the 3rd time I send the documents, and I did it manually (not through the in-app automatic procedure) as they asked.
I talked to support (via chat) for the second time today. A Bot answered. I’m waiting for the results.


#4

I hope it works out! :smiley: You can always type “Live agent” into the in-app support chat if you want to be transferred from the bot. I also recommend contacting them on social media if it takes too long to get an answer in-app.


#5

Josep from in-app chat support just solved the problem. :thumbsup: