Security Settings not active


#1

Hi!

I received my Revolut card today, even though the expected Delivery date was December 18th.

I now want to edit its Security Settings, but the app is not allowing me to do this.

I have a standard already verified account (topped up with fiat and crypto).

Could you please assist me with this?

Thank you!


#2

Did you tried using the card in an ATM and check if it’s working after?


#3

Still at home :slight_smile:

Will post an update if this will solve it.

Thank for your help, Alex!


#4

Mine is on the way so I’m not sure about this but that should be the method (to proof it arrived).
Like on normal cards, activate the card by making a transaction at the ATM.

Keep us posting, I’m curious too as my card will follow a looong route till it will arrive at me.

Numai bine! :laughing:


#5

Yes, that should do the trick.


#6

Have you received the card?


#7

Hi!

Yes, I received it today, but did not get the chance to try it at an ATM.
Will do that tomorrow.

Via the Support chat in the Revolut app I was told by a CS agent that because the “Expected delivery date” was December 18th, I will only able to edit the Security Settings only starting with that date, not sooner.

Even if I already have the card.

Could you please confirm if this is the case?

Thank you in advance!

Best,
George


#8

Could you please try to log out and log back in the app?


#9

Did that now - nothing changed.

Also deleted and reinstalled that app - same thing.


#10

My card is on the way.

Didn’t saw that on iOS but on android Tablet is appearing:

Use the card PIN first
Your first purchase should be made with your card PIN

Maybe it helps :slight_smile:


#11

Just used my card at an ATM and the Security Settings became instantly active.

So that solved it. :slight_smile:

Thank you for the tip, Alex!