Revolut app: we are sorry, something has gone wrong


#1

Hey there,

Anybody experience the same? I just upgraded Revolut and now I can’t do anything cos I always get:

We are sorry, something has gone wrong. Please try again later.


#2

Try to delete and install the app again. This might help you out. It could be that :r: is experiencing a lot of traffic and new users due to the premium feature which rolled out.


#3

nope the system was down. Its working again.


#4

I have the same problem.


#5

Did you try delete and reinstall the app?


#6

the same problem, but reinstall not help


#7

Same issue. Still can’t get into my app :frowning:


#8

I get the same message. Reinstalling the app doesn’t help.


#9

Same here. Can’t sign-up to the app.


#10

On revolut’s twitter it says “Unfortunately, the issue is impacting app functionality. Our tech team is working to fix it ASAP”. But the last update from Revolut was 1 hour ago.


#11

Same. Cant Login. Cant sign in. Something went wrong Problem.


#12

Cards refused in Spain this morning - same technical issue? Not just us?
Alan


#13

Me too. My card was declined too but I am sure I have the funds in there. Has this been happening to anyone else?


#14

My card refused as well in UK.


#15

I can log in to my app but after I cant do exchange or send any money …Please help


#16

Also happening here. Regardless if on 3G/LTE/Wifi, after a reboot, sign out/in. Berlin, Germany


#17

thanks…not only me then, perhaps something with the system…this morning was ok


#18

Is anyone else finding that they can’t use their revolut card in stores? Declined?


#19

The same message for me (UK), I tried to reboot but nothing happened


#20

The app is still not working. Very unacceptable. Why would it take so long to fix things? That’s people’s money you are holding