"Reset Passcode" function does not work

Hi I’m having the same problem I can’t get into the app, have a new phone and using the same passcode. I can’t call anyone and no app support, unless I can resolve this what’s the point of the card…

Hi, i remember clearly my passcode since it’s my birthday date, but for no reason it changed, i’d like to change it but same issue, can you contact me please

1 Like

Hello, having the same issue could you please contact me by private message? See screenshot below


Please help me, I can’t access my account after I changed my phone to iphone SE 2020.
Reset passcode doesn’t work, I tried several times, same issue…

Can you contact me please?

Hi I’m having the same problem I can’t get into the app, have a new phone and using the same passcode. I can’t call anyone and no app support.
Can you please help me?
Thank you.

Hello. My husband also has problem with passcode reset if someone can please contact me as it’s not allowing him to reset and he cant get into his account. Thanks


I was able to make the “Forgot Code” process work this morning. So everything is now OK for me.

Thanks and I wish you all a great day.

I am having the same issue could someone contact me please. I have changed phones and now passcode is not being recognised.

I also have the same issue after changing mobile phone. Passcode does not work, and when trying to reset it an error message pops up.
I haven’t been able to access it for like 2 weeks now. Please help !

Hi. Not exactly same problem, so sorry for that!
I have been using TouchID for a while until few days ago app just said too many tries and started asking for passcode, which I have forgot. Reset passcode function might be working, however it asks for Revolut card details, which I do not have as I have been travelling for a while and I do not have it with myself nor the card number is available elswhere. I would be very thankful if someone could contact me as I cannot use in-app chat at the stage I am stuck at.

Hi, I have apparently forgot my passcode so I cannot login to the app, although I am sure I have entered the correct password.
Atm my revolut card is in Colchester, and I am in london so when i go thought the steps of resetting my code, I enter my mobile number and then it asks my card details.
Is there any way of getting into my account without my card?
I know the amount of money inside the account and who it is from.

Any help would be awesome.

Hi I too cannot reset my passcode
Nothing works
It skips over steps and repeats steps
but never gets as far as reset passcode
can someone please help me

I have the same issue. I have finally received an email that my account is ready, I updated the app, entered my phone and what i thought is my password and the app says that either my phone or password is not correct. There’s no way to re-set the password as on next attempts on event of entering the phone number, I get the error “The verification code or phone number you entered is incorrect” I’m stuck in the loop! I tried re-installing the app, the same thing. Can you help me?
Using iPhone 8 Plus IOS 13.6

Hi @anon33247966,

I have the same issue, the app forced me to do the update, and I am not able to access anymore, It started with resetting the passcode, but when I tried to reinstall it, it gets blocked when it takes photo to verify, I think the last update is full of bug, or it is not compatible with the Pocophone android version, please I need to get access to my Revolut

Thanks in advance

I have the same issue. Android 9 phone latest app update. I don’t get past the confirm new pin screen.

I am having the same problem

I have someone from a different device trying to authenticate and can it reset my password

Using an interims phone since my real one broke. Same issue, PIN doesnt work anymore, PIN reset stalls and doesnt work either. Cant log in to use help service since it wants a selfie but front camera on my spare phone doesnt work

what to do ?

Can customer service please call me simply ??

I have tried to block my card but the robot says I am using wrong data, I am not,

And please call me very worried about security!