All the features under the “cards” button/tab seem to me to be some sort of security feature. So…
How about renaming the “cards” button to “security” or something more meaningful than “cards”?
Then rename the “security” tab/button to “additional protection”. The give away that something is slightly awry here is that the “security” tab needs an explanation next to it. It would seem preferable to have self describing tabs/buttons