Received physical card, it does not work


#1

Hi,

I’m trying Revolut on the recommendation of a colleague and have ordered a physical card. Despite having £5 credit on the card, and having all the security options turned off (location-based security is off, disabling of all features is off) I cannot complete small transactions, for example in Tesco.

Have I missed something? I appear to have enough credit and yet cannot pay using this card. I have not tried withdrawing from an ATM yet. I would like to test and see the card work before topping it up and using it overseas … and so far there’s no sign of it working.

Can anyone help please?

Many thanks,

Stephen


#2

And yes, the card is enabled in the app.


#3

Out of interest, have you already paid for the physical card? Just thinking. I know a certain amount of credit is blocked to pay Revolut, but I thought this occurred before the dispatch of the card.


#4

Hi,

This is a physical card which had been paid for. I initially credited my account with £10, and used £5 to buy the physical card. £5 remaining credit.

Cheers, Stephen


#5

I’m hoping that I’ve missed a simple step for card activation / use however don’t see what else to do.


#6

My card worked out of the box, since you have all security features turned off it should work - might have to talk to support about this one.


#7

Thanks for confirming. I’ll look them up.


#8

Please complete a Chip & Pin transaction first before attempting any other types of transactions!


#9

Hi there,

It might be that what you think is “enable” means actually “disabled”:
Pink (or Purple…not sure of this colour) means disabled, grey means enabled…it is probably an obvious thing and you have already checked…but since I did this mistake at the beginning… :sweat_smile:

Btw, the first security check works the other way round

Hope it can help
Cheers
E.


#10

Hi Emanuele,

Many thanks for your reply. I’ve double checked and all security options are set to grey, so I think I’ve worked my way around the double-negatives :slight_smile:

I’ll try the chip and pin approach as previously suggested and go from there.

Thanks,

Stephen


#11

The chip and pin worked last night at M&S, and the contactless soon thereafter. Things are looking up!
Many thanks,
Stephen