Problems since 5.5 Android Update - Resolved


#1

Hi,

today I received version 5.6 but since the update to version 5.5 I have the below issue:

  • Accounts -> click EUR/NOK/GBP/USD account -> Exchange
  • Cards -> Add (+) -> Physical/Virtual

Result: We’re sorry, something has gone wrong. Please try later

Do I have to re-install the app?


#2

works for me™ :wink:

try clearing the cache storage first


#3

Thanks, but that’s what I tried first.


#4

Logged out, stopped the app, cleared the buffer and removed all data, uninstalled the app. Installed the app again, immediately received an update, installed the update and logged in again. Same error. :frowning:


#5

it’s very interesting you had this problem since 5.5 while no one else has reported these symptoms here. Maybe @AndreasK has heard something.

would it be possible to try on a different device or connected to the internet in a different way? it seems to me like there is something on your account or network causing it.


#6

Tried 4G and wifi at home and work.

I’ve received the 5.5 update four or five times last week. Strange, that after fresh install of 5.6 another update pops up. Maybe an issue with the :austria: Google Play Store?


#7

If it’s a problem with google play in Austria I think we would be seeing a lot of people complaining.

That leaves me with:

  • something on your :r: account or,
  • something on your google account or,
  • something on your device.

Android supports multiple users, if you can set up a new android user connected to a different google account or a separate phone with or without a different google account that could help narrowing it down a bit.


#8

At vielfliegertreff.de there is a posting about this or a similar issue:

https://www.vielfliegertreff.de/kreditkarten/91465-hat-jemand-mit-revolut-erfahrungen-299.html#post2643182

I’ve sent a message to the in app support.


#9

just for curiosity, can you try setting your phone to english temporarily? it wouldn’t be the first time things get broken by localisation. a ß or umlaut in the wrong place and, boom!


#10

Same error with system language changed to English (UK)… from Norsk bokmål.


#11

Is this normal that I receive the 5.5 and 5.6 update multiple times? 5.5 … 4 or 5 times and now 5.6 3 times so far. The bug is still not fixed.


#12

And I cannot access More -> Profile -> Price plan and More -> Premium.


#13

have you managed to contact support? @AndreasK?


#14

I contacted in-app support and provided some screenshots and I sent an e-mail to the address published in the Google Play Store. I wrote that I had reinstalled the app several times. Reply so far: Reinstall the app. It should fix the problem.


#15

:man_facepalming: @AndreasK?


#16

Neither does the “Price plan” (More -> Profile) work. The page does not load and I have to kill the app. Have you pushed a beta (or alpha) version to my phone. :frowning:


#17

On Android I also see “Insurance (Coming Soon)” … which is also weird.

I have installed Revolut on my work phone (iPhone 8 Plus) and there everything works.


#18

Update: Even on iOS (11.4.1) I get this error… but so far only when I try to order a new physical card.


#19

I’ve just checked my account and now all the errors are gone. This topic can be marked as resolved. Thanks for fixing.


#20