primary email not accepted


#1

trying to register for new account…all went well until prompted to enter primary email…no matter the email address i enter, clicking on the “done” button does nothing…using bluestacks emulator as my old android phone can’t update android beyond 4.1…any help very much appreciated!


#2

I’m not sure if it is possible to create an account in an emulator. Emulators are not officially supported.


#3

thanks for the reply, frank…was clutching at straws a bit trying an emulator but beats having to shell out on a brand new mobile phone! did read on the forum, a number of others who seem to be using revolut inside one or more android emulators but no luck for me so far!!


#4

Yes, that’s right, but I am not aware of anyone actually setting up an account this way. Can you temporarily borrow a device from a friend for the initial set up? But don’t forget to use your own phone number to create the account. You need to have access to texts sent to this phone number for an occasional 2 factor verification text. Then you might be able to access your account with running the app within an emulator.


#5

ahhhh, right, only discovered revolut today and still all new to me! but no, am on my own on this one and only have my trusty galaxy s2 to hand…just trying out various other emulators just in case…thanks very much, though, for the suggestions


#6

Just for the record, you could install Android 7.1 on your phone via LineageOS 14

https://wiki.lineageos.org/devices/i9100


#7

yeah, i saw mention of lineageos on the forum but looked bit involved! thanks muchly, though, for the suggestion…got a few more emulators to try and if no joy, will take another look at lineageos! will post update if successful so might help others


#8

Hello team. I’m new user and I’m trying to create a new account.
When setting this new account, after I register my home address I reach the screen where I have to set my primary email. I’m writing down my email and when I click on DONE button nothing happens. So I’m stuck on that phase.


#9

alesantiagosp, are you trying this through an android emulator too or through your phone? since yesterday, i’ve tried creating a new account through just about every android emulator out there and still can’t get past the screen where it asks for the primary email address…


#10

have update for what it’s worth…this isn’t an issue peculiar to using revolut app through an android emulator…now also tried on two smartphones in two countries and exactly the same problem…looking at the bugs forum, am not alone in having this problem either…spent hours on this, lost patient now, giving up on revolut