Previous request is still being processed.


#1

I get the above message followed by “Please wait before retrying” when trying to do an outgoing bank transfer.

It is not clear what previous request is being referenced here. I tried again several hours later but still have the issue.


#2

I’m getting exactly this too. Glad I’m not the only one…


#3

I have the same message when trying to “Activate account”


#4

Exact same error here trying to transfer Euros to a bank - been trying for the past 7-8 hours but always get the same error.

Also tried sending details and a screenshot in the support section the Revolut app and “Rita” told me they were busy and someone would be with me… in 2 HOURS! :flushed:

Is someone from the Revolut team looking at this? Seems to be a widespread issue …


#5

That’s what I got too. This is the answer I got from support which wasn’t particularly helpful. Understand it’s been a busy day for Revolut, but this is quite a fundamental problem that’s been going on for hours…

Hopefully they will sort out tomorrow, bills to pay!

Due to the overwhelming demand today, some customers are having issues with some in-app functionalities. We are
working on fixing the issue. Thank you for your patience and understanding.
Usually I would for sure stay with you for longer and answer all your follow-up questions. But we’re experiencing a high volume of requests due to overwhelming demand today. That is why I will resolve this chat now. I apologize for that. If there’s anything urgent which you need help with, feel free to reopen the chat or come back to us tomorrow. Have a nice day!


#6

Just got the same canned response from someone in support too :pensive:

Guessing the “overwhelming demand today” is due to the new crypto offerings, but to be honest (and I say this as an experience software developer) providing new nice-to-have features at the expense of core existing functionality is a pretty terrible “update”!

Please sort this out soon @revolut !! :frowning:


#7

I had the same issue trying all night yesterday with no luck. What’s more in my case the live chat support was offline due to “high volume” of requests so there was practically no support. Their only suggestion was to check the FAQ…

Eventually this morning it worked.

But being unable to use my money IS urgent and not the stupid cryptos (you have more faq for cryptos rather than core functionalities). Although I like the service I fear that my money is not safe with you @revolut.


#8

Yes, confirmed working now :slightly_smiling_face: