Please update your app as your current version is no longer supported

Hi.
We have two brand new iPhones, both running iOS 17.3.1 and Revolut Business app (com.revolut.business) version 4.37, and in both cases we are unable to login because of the message in subject:

Please update your app as your current version is no longer supported

We had 4.36 until this morning and was behaving the same, unfortunately upgrading to .37 released today didn’t solve.

1 Like

Hello @maxxer :wave:,

Welcome to our community. I am sorry to hear that you are unable to log in to your business account. :frowning_face:

Please follow these easy troubleshooting steps:

  • Reset your password (web) or passcode (mobile app)
  • Set your browser to incognito or private mode before logging in
  • Clear your browser’s cache and enable pop ups
  • Try using a different browser
  • Make sure you have Revolut Business mobile app (black icon) and try to reinstall the app again
  • If you have changed your phone number, contact our support team.

If none of the above steps work for you, please submit a request here or get in touch with support: go to SettingsHelp page and scroll down to chat requests. If you can’t log in, click here and then click ‘Contact us’ (you’ll be asked to fill in some information).

Was this helpful? Let us know.

  • Yes
  • No
0 voters

SG | Community Team

Hi. Thanks for the reply.

This happens on two different phones, not with the browser but on the app only. Browser works fine.

We are in contact with support, but haven’t received a solutions yet. They suggested to clear app cache, but there’s no such feature on iOS. We deleted the app and installed again from scratch, same result.

1 Like

@maxxer, Please follow the below steps to clear the cache in iOS :arrow_double_down:

  1. Open the Safari app on your iPhone.
  2. Tap the bookmark button, tap the History button, then tap Clear.
  3. Below Clear Timeframe, choose how much of your browsing history to clear.

Note: If you have Safari profiles set up, select a profile to clear only the history of that profile, or select All Profiles.

  1. Tap Clear History.

You can check the steps here as well.

SG | Community Team

It’s not a browser issue, it’s an APP one!

Solved via support: they suggested not to tap on the proposed login email address, but Use another address, enter the email address account (the same of the suggested one), and attempt login. This worked.

1 Like

@maxxer, Great to hear that your issue got resolved. Keep exploring our community. :r:

SG | Community Team