Payment links not working in the app

When clicking on payment links I am redirected to the Revolut app but receive an error screen. Happens for all usernames. The links work when they are opened in a browser, but not when redirecting the app. Could this be fixed?

2 Likes

Hello @jackandrew :wave: ,

Welcome to our Community. We are sorry to hear about the error message you’re receiving. :frowning_face:

Have you tried the following troubleshooting steps?

  1. Make sure your Revolut app is updated to the latest version available
  2. Clear the device’s cache:

iPhone: ‘Settings’ → ‌’General’ → iPhone storage → search for the Revolut app → select ‘Offload app/clear cache’

Android: ‘Settings’ → ‘Apps’ → search for the Revolut app → click on the app → tap ‘Storage’ → clear cache

  1. Close the app (close it completely from the app switcher)
  2. Turn your device on and off
  3. Try with both Wi-Fi and mobile data — ensuring that network connections are strong and stable
  4. If none of this helps, use an alternative device (if possible)

After finishing these steps , please try to click on the payment link again and let us know if you face the same problem. :pray:

SG | Community Team

1 Like

Hi @SG.Mandal - thanks for getting back to me. I’ve followed all of these steps and am still having the same issue. I think it is an issue with deep linking in the Revolut app. Would it be possible for the team to get this fixed?

1 Like

Hello @jackandrew :wave: ,

Really sorry that your issue has not been resolved yet. We have forwarded your issue to our relevant team. Kindly allow us some time. :pray:

SG | Community Team

1 Like

Thanks @SG.Mandal! Please keep me posted

2 Likes

Hello @jackandrew :wave: ,

To get to the root cause of this problem, we’ll need to thoroughly examine your account which is not possible within the Community at the moment. Could you please contact us through the in-app chat? This way, we can quickly resolve your problem. Thank you for your cooperation. :pray:

SG | Community Team

1 Like