Opening account": impossible to set up address

Hello,

I have tried to open an account ( I live in Netherlands).
After getting the confirmation message, I have been asked to find my address.
Using the search tool I found it, but when all the details are in place, the “NEXT” button is greyed and I cannot proceed further.
I have tried inserting the address manually but nothing.
I have noticed that the second line for the address is empty. I have tried also to put some info there ( like house number) but still nothing.

Any suggestion?
Thank you

@geniaco Hello, Welcome to the community team. :star_struck:

I understand the frustration you’re facing while signing up for Revolut in the Netherlands. :slightly_frowning_face:
Can you please try deleting and reinstalling the Revolut app from your phone? This can sometimes refresh the system and resolve unexpected bugs. :thinking:

Veda | Community team

Hello, I have tried uninstalling and reinstalling but nothing.
This screenshot has been taken by a colleague

Done on the bottom is greyed.

@geniaco Hello, Welcome to the community. :star_struck:

Please contact us through our Social media channels using the below links so that we will be able help you resolve the issue asap :

Our support team will definitely help you with this. :pray:

Veda | Community team

Hello.
I have tried to contact them but they asked the number I used to register.
I have tried to explain that I am not registered yet.

I have opened a REvolut account in UK and in Italy in the past and was not so tricky. That is just the address section… :roll_eyes:

@geniaco Hello, Welcome to the community. :blush:

Could you please let me know which Social Media platform you contact us on? :thinking:

Veda | Community team

Facebook.
But as I mentioned this should be very easy to solve it.
It is just an address

@geniaco Hello :wave: Were you able to resolve this issue? :thinking: Please let us know. We are waiting.

Veda | Community team

Unfortunately not.
I have tried for me and for a friend we have same issue.