ONE WEEK!!!!! Nobody to answert the chat for one week!!!!???


#1

Nobody to answer the chat for one week…
I have an issue to solve, but nobody answering through the Revolut chat, for one week!!!
How can I reach the team?
Thank you
Bassel


#2

Exactly. I also wonder how to contact them because the in-app chat is still offline. And I have a problem because they charged me for the physical card delivery even there is a promotion that you get your first physical card for free…


#3

Hey @trojan123 and @Bassel :slight_smile:

Please, both of you, try typing “Resolved” in the chat and, if that doesn’t work, try reinstalling and uninstalling. If that still doesn’t work, you can reach :r:'s fast support team through Twitter:

Let me remind you that :r:'s support is 24/7 and therefore if the support chat appears offline then it’s rather a glitch than a normal situation :wink:


#4

Hey @trojan123 :slight_smile:

Did you get it with a tracking code? :wink:


#5

The chat is ONLINE… not offline!!!


#6

Hey @Bassel :slight_smile:

It’s @trojan123 who mentioned the chat was offline, not you :wink:


#7

Now I agree, it is online, but what is the tracking code?


#8

No tracking!!!..


#9


#10

Hey @trojan123 :slight_smile:

When did you order the card?
If you ordered it with a tracking number, it’s a paid extra. If you didn’t, you should get in touch with the in-app support team (or through Twitter if it doesn’t work) to get a refund :wink:


#11

I didn’t get any tracking number. I ordered my card just an hour ago and chosed Standard Delivery. OK, thank you very much for help! :wink:


#12

Hey @trojan123 :slight_smile:

If you ordered it one hour ago, it would be impossible for you to already have a tracking code :wink:
Try to type live agent in the support chat and ask for a refund, as this seems to be a glitch.


#13

Only for premium accounts.


#14

Not at all, @alessandro. For every single customer.


#15

Thanks, I did not know that.

Someone should tell their webmaster though :wink:


#16

@AndreasK, @alessandro is right. The support opening times are incorrectly displayed on the website.


#17

Hi there. We are sorry for the delay in getting back to you. We have responded and resolved your query. If you need anything else, please let us know.


#18