No decimal separator in Bank Transfer page


Ok, when I top up my account, everything is fine with keyboard, but when I go to the Bank Transfer page, there is no decimal separator (.) in the keyboard. Revolut App version is latest, 4.11.0, Android 6.01.
Like this on the pictures:
Ok, there is decimal separator in To Up page

And Bank Transfer page, no separator:

Don’t know if this is my device only problem or has anyone else also such behavior?


Indeed its a big problem @AndreasK can you have a look?


Hmm. Thanks for the feedback. We’ll have a look.


I have this problem. I have just updated to the latest version on android phone but in bank payment screen no decimal separator.


Are you using an Android?


Not only bank transfers has this bug. Decimal separators are not working at all. Decimal point makes the amount underline so I am assuming something happens on the back, but never inserts a decimal separator. Comma is greyed out and disabled.

I am surprised if this were a new issue as I could not use any decimal separator but in the previous Revolut app, version 4.21.0.
There was a different sign ,- for it, but that worked properly.

Now I updated to 4.22.0 and can’t use the cryptocurrency exchange with fraction. There is a workaround, if you type 1 EUR than XRP will have a floating number then change the order and modify the (decimal) numbers. But take care deleting the numbers around the separator as that could make the decimal separator disappear.

Using Galaxy S8 Android 8.1


This pops up from time to time in the community. Workaround: different keyboard. Gboard from Google works fine. Maybe it even helps to switch from QWERTY to QWERTZ. :slight_smile:


Execuse me!?
It’s the numeric keyboard which is the default on every Samsung device at the exchange screen. I don’t have a chance to change to qwertz because it’s a numeric keyboard.
I don’t want to install any other keyboard.

Revolut app works with fraction numbers and the most important user input fails and Revolut is not even considering to fix this even this pops up again and again?


What, if it is a Samsung problem? Considered that already?


Thanks for the advise but it’s a 3 years old entry, latest post is 2 years old if I see that correctly.

If we want to solve a problem we are not posting Google results approving the problem existed since ages. Here is a possible solution, what exactly is what I saw in 4.21.0

Take a look please:

Go further down when reading. It’s about locales.

It seams this goes back to Google since 2009 :slight_smile:

I find it interesting that 4.21 version worked well.

It has both of the keys point and comma in version 4.22.0. Version 4.21.0 had a different sign ,- instead of , and worked.


Well, if it is an issue with Android itself I am afraid that the reason for the stagnation is that the Gboard works fine. So Google might feel responsible to fix anything.

Especially when other companies like Samsung, LG, Huawei etc. modify the Android anyways.

Gboard on Stock Android is great and the numeric pad works just fine at any time.


Yes, Samsung s5 mini


In my case, not even Gboard is working.
I tried Gboard, Swiftkey, and default Android keyboard.

In every case, I can see the decimals on the keyboards but none is entered when I click on it.

I use Lineage OS on a Honor 5X.



Revolut version: 5.5
Android version: 8.0.
Phone: Huawei P Smart
Gboard or Swiftkey

I have the same problem. :frowning_face:



This issue has been resolved on the latest version (5.6)!


oops… not fixed. I still have the issue

Revolut v5.7
Samsung Galaxy S7, french
Android 7.0
Samsung Keybd

It works with Gboard. GBoard has both dot . and comma , keys.
Using the comma key works.

I prefer the Samsung keybd. It is a workaround to switch to GBoard just for Revolut transfers with decimals.


Hi Alak, to confirm, your android phone is in french language and you are being presented with a comma option on the stock samsung keyboard when performing bank transfers?

I have an S7 android 7.0 in french language and this is my experience. the comma functions as a decimal in french locale setting allowing you to define cents/pennies.

kind regards



  Yes, android phone in french language. Galaxy S7 updated today to android 8.0 and it does not change the behaviour.

  The stock Samsung  keyboard shows both comma and dot keys. The comma key is greyed (not accessible) and the dot does nothing in the Revolut app.



Thanks for confirming Al, I’ll speak to my team. Regards


Hi, unfortunately we dont seem to be able to re-create your issue. android can sometimes be very frustrating to handle. The vast majority of our android users have no issues in specifying the amount in decimal places, perhaps there is something else unique in this situation.

I have a samsung S7 on my desk in french language, with french samsung keyboard and have tried in both android 7 & 8. the bank transfer and top up screens all display a ‘.’ which functions as a ‘,’ for the currency on the screen. So no issues unfortunately.

Can I please suggest that you use the google keyboard. we will be soon stopping support of android 4.4 which will mean we can update our apps core functionality and so perhaps resolve your issue in the future.

Kind Regards