no commas

no commas on the keyboard only when i want to make a bank transfer. everywhere else is ok, for example exchanging or sending money to friends etc. FIX it as soon as possible!!!


Please be more specific:

  • phone model
  • operating system
  • which keyboard (standard or third- party)
  • which Revolut revision

android 8
standard samsung keyboard
revolut app 5.3.0
samsung galaxy A5 2017

Hi there. As a workaround could you download GBoard and see if it works?

Hi, I have the same issue on my account, when doing bank transfer I can not input comma.

Phone: Motorola Z2 Play
Android 8.0.0
Revolut 5.4.0
Keyboard - GBoard

Thank you for support

Please try to use dot instead of comma.

Already tried. Both dot and comma don’t work.

Same problem here.
It is not possible to enter fractions (e.g. 0.10€ - 10 Cent).
Neither pressing “.” nor “,” does anything.

Phone: Motorola Moto Z
Android: 8.0.0
Revolut 5.4.0
Keyboard: SwiftKey Beta

It does NOT work if the keyboard language ist set to German (Germany).
It DOES work if the keyboard language is set to English (UK) - “.” then works for fractions.

I have the same problem:(

5.4.0 is good now. everything working.

5.4 still showed the same error for me today.
However, updating to 5.5. helped: now a comma shows up whenever “.” or “,” is pressed.

Hi, I have an LG G4, Android 6 and I can’t type a comma or period when trying to set an exchange target rate for the JPY (RON > JPY or EUR>JPY). It works for other currencies. I tried LG and Google’s keyboards. I tried copy pasting the value with both a comma and then a period, but it pastes them without the comma/period.
My friend who has a Nokia 7 Plus has the exact same problem by the way. It works on my Ipad Pro though.

Oh, silly me, I forgot: using android (Google Pixel 3a), latest version

I have the same problem: french or english keyboard, GBoard or Swiftkey, copy-pasting a dot or a comma… It always disappear. And it’s quiteannoying if you want to move or pay out a precise sum to an account!
Also, but possibly unrelated: when exchanging currencies, the app does not show the converted sum in the target currency.

1 Like

Samsung Galaxy S9
Revolut version 6.29.1
Gboard keyboard

I used Gboard in order to type decimal numbers.
Since approx last two weeks the comma disapairs.
And also the same problem with the rate converter

1 Like

same problem with a v-smart active, android version 8.1.0
it’s happening since January 2020, google keyboard or Swiftkey

same issue here. no comma and can’t pick the balance for exchange anymore - before was ok.
=> no more option to sell my BTC

revolut version : 6.31-beta-140 / was same issue on latest public version
Mate 10 Pro on android 9
using swiftkey or gboard

1 Like

Same problem here!
The comma/decimal separators appear to never work.

  • Buying/selling cryptos is impossible
  • Also, when topping-up from credit card, it’s easy to not notice the missing comma and typing 100x more than I intended.

I’d hate to sound harsh, but this is unacceptable and must be fixed ASAP.


Same issue by currency exchange… I can not setup a exchange rate without any comma. A shame.

1 Like

Same issue when trying to set a objectif rate for automatic exchange with:
Sony xperia z2 compact (android 10)
Revolut version 6.32.1
Gboard (but tried with others as well)