New card, PIN not working

I just got my new Revolut card, I’ve loaded money, but when I made my first PIN transaction, the card was declined. I had the PIN pulled up on my phone and entered it exactly as it appeared in the app. However, all tries failed and now the card is frozen. I’ve contacted support via in-app chat but have not received a reply. Please advise. I would like to start using my card.

Was it chip transaction? Please remember that first transaction has to be chip&PIN.
I strongly recommend withdrawal form ATM.

https://www.revolut.com/pl/help/cards/my-contactless-is-not-working?lang=en

Yes, it was chip&PIN; however the card machine declined the PIN 3 times. I know it was the correct PIN because I had the app open on the phone as I was entering it into the card machine.

First, I need to get my card unfrozen. Second, I need to understand why the PIN indicated in the app is not working when I enter it into the card machine.

Any other solutions?

Lets summon @AndreasK :slight_smile:
In the meantime you can ask for help via DM on Twitter

Hey! Have you tried to contact our in-app support team?

Yes, he has tried to do this😉

Support finally got back to me and was able to re-activate the card. Thanks for your recommendations!

1 Like