Latest update won't start - can't access.


#1

Since the latest Revolut update the app no longer starts - it just sits there showing the Revolut name. I can no longer access my account or use the support(?).

Anyone else having this problem?


#2

No, I don’t. I suggest you to reinstall the app.
BTW. Are you on Android or iOS? Which version?


#3

All good for me, although they were experiencing some technical problems earlier which now appear to have been resolved in the last few minutes.


#4

I ended up reinstalling the the app & it seems to be working again - apart from the crypto graphs of course, which have never worked.


#5

I am also having this issue. I logged in and it said my identity was no longer verified. I spoke with Drew on the app chat line who suggested I log out and log back in. However I cant even log into the app now. I dont appreciate you stealing my money and blocking access to my funds when you do a software update. How do I fix this?


#6

I’m also not able to access my account. It’s telling me that it isn’t activated and that my cards aren’t activated, even though I’ve been using those cards for the last year. I also verified my account then but it’s telling me I’m no longer verified. This means there’s money in my account I can’t access.

Chat support just ended the chat with me out of nowhere, and this isn’t letting me start a new topic even though I’ve done so before.


#7

+1 exactly same behavior after latest update (5.17)!
Tried everything, force stop, delete cache, uninstall and install (now it says that something went wrong every time that I put my number).
I’m running Android 6.0

Please fix this ASAP!! I’m outside of my country and I don’t have access to my account, I need it to make the regular payments, food, gas, etc. This is not the first time that you have problems with updates, you should plan/test them better because being an bank in a app you can potential ruin the day of someone that needs to use their money. If you don’t have instagram or facebook is bad but if you don’t have access o your bank account it’s just a pain in the a**


#8

I can access my account but i have lag and i can’t Top up from my other account.
Did reinstalling the app worked?


#9

same here, Android Oxygen on One Plus6 Asks for phone number then ‘something went wrong’ clearly it did but some idea from the app of what the problem is might help.


#10

Have the same, after uodate to 5.17 loging page hanging on.


#11

+1, same problem here. After fingerprint login the app just stays at the same screen for about half minute. Then it logs in to the main screen, but the response is veeeeery slow, and exchange is not possibe. It says I have to activate my phisical and virtual cards (I’ve already used them several times before). So something is wrong…


#12

Tried to reisnstall app (cleared data), then I can do nothing. After I tell my phone number it says “We’re sorry, something has gone wrong. Please trty later”


#13

Hello, app not working, I reinstall nad I can’t install again, it Days somwthing went wrong


#14

Had the same problem here. App didn’t open, I deleted it, then stuck on first screen (input phone number). Started working 5 minutes ago…

iOS.


#15

+1, complete reinstallation fixes this issue. Clearing app data is not enough.


#16

Perhaps its a new gimmick to persuade you into a premium upgrade. Otherwise standard users get a more sedate, haphazard and unpredictable experience. :rofl:

Seriously though, I’m sure it will be fixed pronto, if not already.


#17

I have the same problem. After logout as sugested by chat agent, I can no longer log in into my account. It’s all gone. Money…cryptocurrencies…everything.
Try to speak with live agent with no succeed.
I am a premium user and this no way to treat any client.
I am very desapointed and i hope that someone could solve this problem


#18

I am premium user and after log out as instructed by a live agent, all my money and cryptocurrencies had gone. Can not ue my account anymore. Please help. Restore my money and my account.


#19

On my daughter’s phone (iPhone 5), app crashes right after opening every time. Been like this for days now. Serious problem as we need to resolve family finance issues. Not possible to access in-app help because the app crashes immediately every time.


#20

OK, so it’s not just me then…:roll_eyes:

They’re obviously not testing their updates properly before pushing them out, which is disturbing to say the least & irresponsible at best.