Issues with MasterCard Securecode Top Up

Dear @AndreasK @MissG @Juliopp,
I am exactly in the same situation, exactly the same as @MissG (but with a VISA V Pay). I’m very disappointed as well!!!

Everything worked just some weeks ago… i guess that other people will have the same teoubles, in the next future. And, of course will leave the revolut family. Why don’t you try to fix?
Thank you!

@MissG, please let me express my apologies any negative experience you may have had getting in touch with our support team.

I’ll personally review your chat history and forward it to the right team so we can take the necessary measures to prevent this from happening again.

Could you please send me your phone number associated with your account via a direct message?

Once again, apologies.

Best,

Andreas K.

Hi @kurt, I can take a closer look into your account. Could you please drop me a DM with your phone number associated with your account?

Regards,

Andreas K.

Same problem here… can’t top my account. Doesnt working with mastercard or with a visa card.

Hi All!

Yeahhhhhhhhh!!!

Problem solved !!!
Thank you so much @AndreasK and @Juliopp

What about @MissG ?

2 Likes

Hey @kurt,

I did nothing, thank @AndreasK :stuck_out_tongue_winking_eye:
Anyway, I’m really glad the problem was fixed :smile:

2 Likes

How did you get it to work?
I topped up a couple weeks ago ans it worked fine.

Howver I’ve tried about 5 to me a today and they all got declined! :tired_face:

Have the same problem as Tara but with Visa debit card. When expecting security confirmation window from my bank, i see only blank white rectangle with cross in upper right corner.

Country Norway
Bank DNB
Confirmation method BankID Mobile.

Funny thing that it worked on first time (ten days ago), but now it doesnt

Please help if you know how to solve it.

Hi! I’ve also not been able to use some of my cards, namely the ones using 3-D Secure, to top up my Revolut account since the last update of the Android app. In my case, the issues began on the 31st of August. Now, when I try to top up my account with one of these cards, I get the message “All following top ups will be instant” instead of being redirected to the 3-D Secure authentication page; after a couple of minutes I get a message saying the payment couldn’t be authorized and the operation fails. In an attempt to fix the problem, I removed these cards and tried to re-add them, but I couldn’t. Therefore, I can only conclude that Revolut is at fault here.

Type: Maestro
Country: Portugal
Authentication: 3-D Secure
Status: not working

Type: Mastercard (debit)
Country: Germany
Authentication: 3-D Secure
Status: not working

Type: Visa (debit)
Country: Sweden
Authentication: none
Status: working

1 Like

Revolut has a bug in the android app, it seems they know - all we can do is wait and see.

Hey all,

@danielgls that’s the exact same issue I have, same message and same behavior. My card is also a Maestro from Portugal with 3D Secure as well.
The last time I was able to TopUp was on the 24th of August, and when I tried again on the 1st of September I couldn’t.

@Swede Did they confirm that they have a bug on the android app? I haven’t seen any confirmation yet.

Regards,
MissG

Hej!

@MissG, yes they confirmed they know about the bug; the last time I contacted Revolut’s support I was told the following:

Yes, they’re aware of these [issues with 3-D Secure], but since it’s a complicated process there are multiple things that can go wrong with this, on your side, bank side, and simple coding problems, like some Android or iOS limitations. From what I can tell for now suggested temporary fix is top up via android pay, other card or bank transfer.

Is your Maestro card issued by CGD, by any chance?

@danielgls Yap, Maestro card by CGD.
Thanks for the info.

I had asked my Portuguese bank (CGD) for a technical review by their IT team and today they contacted me and told me the following:

We inform you that the operation is not being validated by the merchant (Revolut) through 3D Secure (unlike the last successful validation performed by them on 27/08/2017). Since there are no problems with your card, and bearing in mind that kind of operation must be validated through 3D Secure, we suggest you contact the merchant.

So, for once, I’m now 100% sure the problem is on Revolut’s side.

It’s true. The issue is on Revolut’s side. To workaround the issue, please remove the 3D Secure entry available through your banking site and you should be able to top up your account.

Well, I have to admit that a few weeks after this incident (not sure about the date by now) it went back to normal.

I have no ideia if it was something on my banks side or Revolut’s side (guessing Revolut) but I could topup my Revolut as usual and never had this issue again so far.

I would like to revive this discussion as its happening once again.

Since one of the last updates (not sure which one as I had a few in the last couple days) I cannot top up my account anymore.
I get an error about the 3DSecure authentication.

I do have 3DSecure authentication active (as I had before). The card is the same actually, so the authentication has been always active, and I’ve always used this card for topping up my account.
When topping up, I get redirected to an “in-app page” from my bank requesting the SMS code and after that, the topup fails/gets rejected.

Apart from this situation two years ago, I never had any other issue topping up my account.

I already contacted support twice already (yesterday and today) and the issue is still “being investigated” by the team. Apparently I’m not the only one with this issue, because the support agent said that more users are experiencing the same problem.

Anybody else got the same issue??

I can report a similar issue. For the last 2 weeks, I’m unable to top up using the same card I registered my Revolut account with. According to the bank, there were no errors on their side.

Attaching the screenshot from the 3D verification error after I received and entered the one-time password:

My issue was eventually resolved.

Still don’t know what happened but I could top up normally after a few days.

Have you tried to contact support ?