Issue topping-up with BankID (Sweden)


#21

It gets stuck right after completing all the details of the card. After closing the popup the transaction goes into pending state and after 30 mins it gets cancelled. Sometimes though you can see the bank confirmation screen flickering in the gray popup for a mere second. It seems the popup poorly handles HTML iframes.
Bank: Swedbank LT, Mastercard Debit
Device: Samsung S7, Android 7.0

UPDATE: managed to get through the gray overlay by randomly tapping and swiping in the gray area. The mastercard secure greeting text appeared and then logged in as usual. Seems like your frontend developers got work to do :slight_smile:

ezgif-3-a2f2db27a8


#22

This bug has been around for way too long without any change, affects topups of several different kinds it seems.

Revolut, this hurts your business if you didn’t know it already. It needs attention and confirmation that something is happening else probably many users will give up.

Myself i top-up using SEK international transfers since they happen to be without charge at my bank but it takes between 3 and 5 DAYS to arrive in my account at revolut from the day i send so it’s less than practical.

I wrote about this issue back in July, didn’t expect such a serious flaw in the android app get no attention what so ever more than 4 months down the road.


#23

Same issue for me. Help please, how was it solved for the others? (android / nordea bank)


#24

It isnt solved for me. Android 7 / android 8. Same issue. I get the screen from my bank regarding if to use mobile bank id or banks own solution which I dont have. I press start mobile bankid app and then I go back to top up page and nothing happens instead of starting mobile bank app.


#25

I have this same exact problem!
Seems like Swedes on Android are not Revolut’s best customers :stuck_out_tongue:
It would be helpful to have this solved if Revolut expects more and more users specially when this issue dates back to at least June this year!


#26

It’s quite strange, given that revolut now has more than a million customers and more than half of them will be on android - the forum should have flooded with messages concerning this serious issue with the app?

Either it only affects very few banks or fewer customers than one would expect finds their way to this community. I suspect the latter.

All we can do is keep the issue alive by talking about it so it’s bump’ed regulary, sooner or later someone at revolut will have pity with us and inform the app developers nudge nudge, know what i mean @AndreasK :1st_place_medal:


#27

I’m having the same problem. Nordea bank on Android.

I’m surprised they have allowed this bug to persist for so long. Any update on when it will be fixed?


#28

Thanks for your useful feedback. I’ve passed this to the tech team.


#29

Same problem here. I go to BankID app and verify myself, but when I go back to Revolut app, nothing has happened and redirects me again to filling in card info.
(Also Android/Nordea/BankID)


#30

Any news on this issue?

I’ve tried before with the same problem and tried again today and same problem with BankID.

Here’s what I actually do:

  1. start BankID app
  2. start Revolut
  3. go to topup screen and fill in my card info
  4. it sends me to the “verified by visa - nordea” screen where I can pick either BankID or regular banking device / card reader
  5. Here I’ve tried different things with different to no results:
    *I’ve pressed continue on BankID and it takes me to another screen where I can press “start app”. When I do it moves to another screen and then it says “web page not available” and "The web page at intent:#intent;scheme=bankid;package=com.bankid.bus;end; could no be loaded because: net::ERR_UNKNOWN_URL_SCHEME. there’s also a popup message saying “We’re sorry, something has gone wrong. Please try later.” with an Ok button. When I press ok it takes me back to the top up screen. On the main screen there’s a pending payment that goes away after an hour or so.

*I’ve tried to press continue on BankID and then manually switch to BankID where I can confirm / accept the payment by entering my pin-code, but when I switch back it takes me back to the top up screen. And as stated above, when I go to the main screen there’s a pending payment that disappears or goes invalid after an hour or so.

However… it now works with my regular “bank security device” whereas it didn’t before. So for anyone out there who has a security device / “bankdosa” around then try with that instead for now.


#31

Keen to know if there has been any progress concerning this bug? I have yet to successfully top up when 3d-secure is involved and this has been the same for more than 6 months now.

It’s a shame really, i’d like to use revolut as main card but it’s impractical when i have to do international transfers that won’t show up in the account for an entire week instead of a quick top-up in minutes.

(Basically just bumping the subject)


#32

I would also love to hear anymore on this issue @AndreasK. I just got my Revolut card today but found out the hard way that when I try to top it up using SEB and BankID on my android phone, it errors and doesn’t work. Even the alternative method of using a one time code also fails. So now I have a pointless card that was supposed to change my life when living abroad…

I get the same error as @wastah with the webpage not available. When trying the One-time password I get “Sorry something has gone wrong” popup, then the app shows that the top up was successful. So no idea if it actually worked or is going to be reverted.


#33

Are you using Android or Apple Pay?


#34

Hey Andreas, I am using Android 7.
It appears the final attempt to top up using a one time code worked. So now I have a list of about 8 failed attempts and 1 successful attempt to top up. But top up via SEB and BankID still fails.

Also I struggled to add a beneficiary too, it failed to add myself, and took 2-3 attempts to add my own bank as a beneficiary.


#35

@AndreasK Are you looking at this issue for swedish users? Seems to be a problem with android regardless of verison and the Mobilt BankiD.


#36

I’ve worked with @AndreasK to try and obtain visual evidence of the issue (with bankID specifically for me) and believe that has been passed onto the team. No news yet on whether they know of the issue, have a solution or are working on it though.


#37

I’m having the same issue now, i’m using Nordea. Did anyone find a way to fix this?


#38

I can’t fully remember how I got around it but now mine is linked and when I top up it just charges my card with the amount. (I don’t want to delete it and re-add it to check in case it doesn’t work)

I think I had to use the one time passcode option rather thank the BankID one. Still not heard back from them if they can replicate the issue or know what the issue is after working with them to show them what’s wrong.


#39

Same problem with IkanoBank/Preem card.
Had to use anoher card with mastercard secure code


#40

Got the same problem using Ikano bank Shell MasterCard and BankID. Any news om a bugfix?