Impossible to create Revolut account


#1

Since over a week, I have been trying to create an account, but to no avail.
Whatever I type in in the address fields, and no matter if I fill in all the fields, upon clicking Next, I get:

“Please fill in all fields in the form”

I tried various addresses, various combinations of address, using only latin characters. Nothing works. There is no way around it.


#2

Hi @lockheed,

Thank you for contacting us.

Could you please let me know where are you based?

Best,

Andreas K.


#3

Hi,

I have exactly the same issue.
I AM in France, the revolut app is up to date.


#4

I have this same problem from few days. I’m in Poland.


#5

I just told a colleague of mine about Revolut, he just tried to subscribe, and got the same message “Please fill in all fields in the form”.

We are in France.
All fields were filled.
After getting the error message, the app points to the postal code field, even though it’s filled with valid data.

Hope this helps and hope it’s fixed asap.


#6

Funnily enough they blocked my forum account for starting this bug thread… An unusual approach to fighting bugs.
Anyway, I’m from Poland.


#7

Account seems functional.


#8

Not really.


#9

-1) It’s automated.
-2) (I think) every user gets this. It’s unrelated to the content of your post.


#10

-1) I haven’t been on hold (yet?) with this account.
-2) Your account was placed on hold and released the same day. Mine is on hold since two non-holiday days already.

Regardless, it is quite annoying when AndreasK from Team Revolut asks you a follow up question, and you cannot answer because Team Revolut’s forum put your account on hold.


#11

I have this same problem today. I’m in Poland.

In adress place I get “Please fill in all fields in the form”


#12

I’m based in Poland.


#13

Please fill up all the fields! Use English alphabet with no accents on the letters.

If you need any help, drop me a line.

Best,

Andreas K.


#14

Please fill up all the fields! Use English alphabet with no accents on the letters.
If you need any help, drop me a line.
Best,
Andreas K.

AndreasK, thank you so much for that brilliant answer!

Just one more thing.

Could you please clarify whether you think we are morons who, when they see the message “Please fill in all fields in the form” during account creation for the 30th time it did not occur to us to… I don’t know… fill in all the fields in the form?

Or was it because when I wrote in the opening post of this bug thread:
“no matter if I fill in all the fields” and “using only latin characters” it was somehow too confusing to convey that I did try to fill all the fields and am using only Latin (which means the same thing as English) characters?

I do realise this post may seem not very nice, but neither was waiting nearly 5 days for your answer and then getting this piece of worthless advice evidencing that you don’t give a damn about wasting our time and just can’t be bothered to do your job properly actually reading the thread you are replying to.

Instead, please fix your damn app so I can give you my money.


#15

Sorry @lockheed but not every user is experiencing the same issue. I was referring to the previous user and not directly to you.

If you’re experiencing an issue you can send me a direct message and I can help.


#16

@AndreasK, sorry but I do not see a way to send you a direct message on this forum.
Besides me starting this thread is a good clue I am experiencing an issue, so I do not understand your “if”.
I don’t know what other information I could give you that I have not yet given here, so perhaps you can send me a direct message. Although I am not sure why not keep the solution public as it clearly affects not just me.


#17

I have sent you a DM, & looking forward to resolve this.


#18

@lockheed - Ten błąd występuje gdy po wpisaniu kodu, system znajduje miejscowości ale bez tej którą chcesz wybrać i wpisujesz ją ręcznie. Ja to obszedłem w ten sposób że podczas podawania adresu - po wpisaniu kodu znajdowało mi inne miejscowości a nie właściwą dla mojego zamieszkania. Wybrałem dowolną przypisaną do mojego kodu pocztowego i poszło dalej. Po przejściu tego formularza i założeniu konta wszedłem w ustawienia i ręcznie zmieniłem miejscowość na właściwą.