I can't log in with my password

Also having same issue, updated the operating system on my iPhone now locked out.

Hello Same exact problem today!
The code is corect but impossible de login…

1 Like

I have the same problem… did you fix it? It freezes and then goes back to put the number to recover the password…

1 Like

hello mate , can you help me please? I have same problem with my password from account, isn’t working. I reinstalled the app again and doesn’t working… I have iPhone 7 and iOS 13.4.1. but I forgot pin. After entering my phone number and pushing link "forgot’ I receive the e-mail but after that I have got message“We’re sorry, something has gone wrong. Any suggestions or solutions? Please help me. Thanks you

1 Like

Hi I still have the same issue.

Deleted app updated phone tried a different phone still nothing.
Customer support sucks big time.
Been over 2 weeks NOW!!!

I’m having the same issue. I can’t login. It says the password is incorrect but it’s the same password I’ve been using since ever.

Hi @AndreasK,

I’m having a few problems with my Revolut account. I’ve recently moved to the Uk from Australia.

I was made aware of all the extra function provided in the UK so I was told by Revolut support team to close my account and reopen in the UK.

I’m now stuck on the phone number screen below. When I enter my passcode I get the error ‘something went wrong, try again’

Please help, Harry

me too!!! please help. and no one send me message.

Same problem as above, I have updated iOS this morning, when I opened the Revolut app I wasn’t asked to log in with the fingerprint but only with the passcode. I requested a reset, received the email, put the last digits of my card and I was told that they were wrong. I was asked to take a selfie with the ID card and after that I was sent to a blank page which was meant to be the chats

hello @AndreasK
my old phone died and I have no access to it right now. installed revolut on a new phone with the same number and now it says that it’s sending me an email for activation, yet nothing is received.

This seems the only way to get support.
I’m unable to access my app since I changed my phone.
Login ask a pins code which won’t work (I always use the same one). Resetting via email (through cell number) will just lead back to Pin request…

I also cant login on the app

Hello, i also have problem with logging, im using my number and password then i get message ’ something went wrong, please tryb again later ’ and i have no clue what’s going on

Same here guys - I am unable to login. My app kicked me out automatically. Now it is telling me my account is empty and I need to sign up, and I actually have money inside the account, stock trading balance, savings etc.

If someone could help, that would be much appreciated.

Changed phone but stuck in loop with password issues. Won’t accept my number and not received any reset emails either. Please help me.

I receive a code with 6 digit not 4 like this for example : 123-456

And on the App the code I must give is 4 digits…

It’s been one hour now I am spendind on this, how can I connect to my account? I need my IBAN.

Thank you for your help

App PIN (4 digits) and security code sent as text message (6 digits) are two different things. You need both if logging in on a new device, for example.

Hi, i need help. I have problem with login to my account. I tried to reset password by email. Every time when I tried to do that I have error in app like there is mistake you can’t do it right now

not even 1 second indeed. And now it does not accept my phone number anymore…

Thank you, I try to connect from the application on my smartphone. It’s impossible because they ask for a 4 digit code or PIN, then you have to go back to ask for auth code, then a new page appears asking for the 6 digit auth code and then disappears after 2 or 3
seconds. It goses back to the 4 digit PIN code. It’s just not possible