galaxy sIII and app....


#1

Hello

i have a galaxy SIII mini GT i8190 running android 4.1.2
i cannot update android
i cannot change my cell phone

play store says revolut is not compatible with my device

how could i open an account with a galaxy sIII phone?

thank you vm


#2

The only known way is to upgrade phone’s software- I mean Cyanogenmod (older) or Lineageos (newer).

Of course you can install Android emulator on your computer too, and then install Revolut on it.


#3

Try installing the application though other channel ( direct apk download, alternative appstore ) and if it’s not working with the last version try older version.


#4

This is crazy. All the unfixed security vulnerabilities. I would use this phone only for making calls and sending text messages.