Fingerprint login not available on Android


#41

Very interesting.
I’ve fist opened app after root without Magisk working.
I’ve now reinstalled Revolut with Magisk working.
no luck :frowning:


#42

I was able to get fingerprint unlock back using Magisk… but after few days it disappeared! Magisk is working fine, because I use other apps that require un-rooted phone. That’s strange.


#43

Finaly, after updating to the last version, IT WORKS !


#44

10 months on from my original post above and this issue is still not resolved. Andreas, is there any update please?


#45

I just became a member here to report this bug, that fingerprint login is no longer working. And then I found this post, so I decided to write here instead of starting an entirely new topic.

Fingerprint login used to be working (it has worked on my device). I have a Oneplus 3T. I have a friend who also has this problem, and he has a Oneplus 3. Both our devices run Android 7.1.1.

For me, and my friend, it stopped working right after updating Android to 7.X.X – so that seems to be the problem for us on Oneplus 3 phones; after updating the OS fingerprint login no longer works for Revolut (however, it does work for any other app that I’ve tested with fingerprint recognition, Paypal for instance).


#46

There is also another thread about this problem: Cannot login with fingerprint on Android

It clearly affects a large number of customers.

Andreas, is there any update?


#47

Hi Andreas,

14 months later and fingerprint login is still not working. Can you please reply & explain the issue?


#48

OnePlus 3T user on Oreo here.
Fingerprint option is not in my Revolut settings.
I’m rooted so that might be the reason, however even if it is the reason it is unacceptable to just silently disable it. Most other apps don’t even change behaviour, some notify that you’re rooted, but still allow you to use fingerprint scanner (this is the case with one other banking app on my phone).
As a developer who also in his work does security reviews for a payment gateway I can’t see a reason for disabling the fingerprint scanner on rooted phones. I do, however, accept that there might be a reason, but in that case please at least let the users know why the fingerprint scanner was disabled instead of just silently disabling it.

Otherwise, please fix this. Typing in a 4 digit PIN while somebody is near you is pretty much the same amount of security as having a piece of paper with your password in your wallet.


#49

changed phone to the new one (Lenovo ZUK Z2 ) with Oreo on-board and fingerprint option disappeared.
Can anyone advise the solution ?


#50

JFI, will reply to myself
I resolved the issue.
It was because of root (magisk in my case).
I turned on hiding option in magisk and it helped. Now fingerprints login works fine.

P.S. I wondered that root affects fingerprints login. My previous phone was Xiaomi Redmi4 and it also was rooted but no issues with fingerprints login.


#51

Please stop the “Are there updates” SPAM, it makes it hard to read all the comments.

TIP: If you want to know if there are any updates just scroll down and see if there are updates.


#52

+1, Magisk Hide resolved the missing fingerprint login in my case. (LG G5 H850, stock 7.0.1, Magisk)


#53

Magisk Hide solved it for me as well :+1: thank you all.


#54

Hiding root in Magisk app worked for me also (Huawei Mate 10 Lite). Thanks Velfess :slight_smile: !


#55

Maybe it would help do to something like this:


#56

Is your phone fully certified by google? When I was using beta version of Android I have same problem, after releasing official version everything was ok. You can check it In Play Store->settings->Play Protect Certification


#57

I’m not sure to whom you’re answering :slight_smile:
I have Nexus 5x with stock ROM - which is normally certified. But I have root, so it’s not :man_shrugging: