Export statements not working

An option used to appear in the top right of the screen to export statements as pdf or csv when scrolling down the Accounts tab. That isn’t happening any more and there appears to be no other way to export transaction history.

It’s important that I have this or else I have to go through the faff of changing my budgeting system. (Alternatively, support a Yodlee integration and I won’t have to manually export statements.)

I raised this with the help chat people and checked in a week later to see if there was any progress but they were unable to give me a timeline to resolution. I know it’s on your radar. Please prioritise the basic feature of statement exports over ‘nice to have’ things.


Hey distraqt

They just moved the option into the Account details page.

On the frontpage tab the your balance and you will see 3 buttons. One of them is “statement”. This is the one you are looking for.

Another way of finding it is: More -> Profile -> Account Details -> Tap on an Account.


Amazing. Thanks for the tip!

Hi, I try to export my statements in pdf or excel, but neither method is working on my moto g6 plus.

When I press the “Get statement” button, I only see a loading screen followed by a “We’re sorry, something has gone wrong. Please try later” error screen.

1 Like

Hi there,
I’m having the same issue as @GiuseppeC, i. e. upon tapping to export statements, I receive the

“We’re sorry, something has gone wrong”.

error. I’m using a Motorola Moto G7+, and the latest version of the app. I’ve tried both Excel and PDF export and restarting my mobile (old Windows habit…).

Any ideas on how to resolve this?


1 Like

I have this same issue. Trying to get a statement, either pdf os excel, and get the

“We’re sorry, something has gone wrong”.

I tried, restarting the phone, reinstalling the app, nothing works. I have a Xiaomi 9T with Android 10. Latest update of the app: 22 Jul 2020.

This is really annoying since its not the first time this has happened. I believe in february I had the same issue. It affects productivity.


1 Like

The problem persists for pdf, but today I was able to download a maximum of 135 lines of csv, so I just limited my requests to a few months each and joined them together manually.

Experiencing the same problem.
When tap ‘get statement’ the error says We’re sorry, something has gone wrong. Please try later

I have updated the app and restarted my phone. It is disappointing as I need my statement quite urgently.

1 Like

Having the same issue. Cannot access PDF or Excel for my EUR account.

I am also having the same issue when trying to print off statements , when i click get statements no matter the month or if pdf or excel i get something has gone wrong… i to need this information urgently.

I installed the application on another device an IPAD and it worked straight away , my phone is still not working but i have what i need for now.

I was having the ame issue so went on to chat and they emailed my statement, but after that i realsied that it works if you go all the way back to when you opened your account it works. So for me it was August 2019 to July 2020 and it worked! When I was speaking to the person in chat they said they can only do statements for your entire history not specific periods.

Both pdf and csv export are working today. I like the option to attach notes and receipts to payments. The notes are exported in the csv but the receipts are only viewable in app

I don’t have an option to export statement at all on my Android device. The statement screen only generates PDF, which is unfortunate, because PDF is not computer-readable.

Do I miss anything? How can I generate a statement in CSV format?

Hmmm, this is how it looks like on my phone:

, and PDF is readable on my Windows PC.
Maybe try update the app…

My app is up-to-date (according to google play store). Interestingly, I just noticed that PDF/Excel options was visible for a split-second when I opened statement dialog, but got hidden almost immediately.

PDF statements reports two accounts (regular “E-money” plus an additional account Lithuanian-registered “Revolut Bank, UAB” (https://blog.revolut.com/transferring-our-lithuanian-customers-before-brexit/), ). I very much suspect that “Excel” option gets hidden because of this.

Could it be true?

My statement has a disclaimer- on the very bottom of last page:

© 2020 Revolut Ltd Revolut Ltd (Company No. 08804411) is authorised by the Financial Conduct Authority under the Electronic Money Regulations 2011 (Firm Reference 900562).
Registered address: 9th Floor 107 Cheapside, London, EC2V 6DN, United Kingdom. Revolut Ltd is an Appointed Representative of Lending Works Ltd (for the activity of “operating an
electronic system for lending” only) and Revolut Travel Ltd (for the purposes of designated investment business only). Transaction information is available through the Revolut app for
six years after you close your account. If you need to keep a copy of the information after then, you will need to download it. You can download information from the app at any time.

I’ve been having a similar problem for about 6 weeks now. When exporting a PDF statement, the Revolut app offers to print it. When exporting a CSV (which is what I need), the app always sends it to Gmail. I’ve talked to support on 21 July, which acknowledged the problem and suggested to just use Gmail as a ‘workaround’, which is not a viable solution for me. No further communication and apparently no fix. Uninstalled and reinstalled the app, uninstalled/reinstalled/reconfigured the default mail app (AquaMail), made sure that mailto: links are handled by AquaMail (not Gmail), reset Gmail configuration and other things on the phone. Phone (Oppo Reno2) and all apps are up to date.

Could that be related to your problem, i.e. could it be that Revolut is falling over when it attempts to invoke the Gmail app?

I’m new here so please be kind…and forgive me if this has been answered before.

I am having all sorts of trouble trying to export a statement to integrate with Wave Accounts. Eg. I can export the statement as a .pdf nice and clearly which is fine but when it comes to being a .csv that the software can read, the format is so strange that the software can’t read it and I need to enter all the data manually (which is time consuming and error-prone). I’ve tried different conversion programs to try to get the formatting correct so the right values are in the right columns but I’ve drawn a blank. I’ve got a Starling account as well and that works perfectly.

Is there something I’m doing wrong here? Even converting the pdf back into CSV doesn’t solve the issue.

Same issue for me. The only way to “download” the CSV statement is sending it through GMail to myself. This is almost a no-go privacy wise. Is there another way or is that user specific? When it really must be email is there any way to change the mail app (I’m using K9)?