Error when using the card in a transport app: "Please use chip and PIN whenever they are available."


#1

So, there is a new public transportation app in Portugal, called “Anda”, for the Porto city transportation system.

They allow cards to be associated with the app for payments (when using the subway, for example).

Two users already tried to link their cards, but when they tried to use the app, they got the message: “Please use chip and PIN whenever they are available.”

Does anyone have a clue why this happens - and if there is a way to fix this?


#2

Hello, did you try yo contact the Anda app support team?


#3

yes, still no answer.


#4

Same issue, just received an email with a failed charge from anda/STCP, and on Revolut it shows the same message that op got. Weirdly enough the 0.10€ for the virtual card was charged/debited without issues.

It really looks like anda’s backend is using two different methods to charge against the same card - not surprised since their app has so many dumb and obvious bugs that shouldn’t be on a production environment at all… another reason why I really want to use a virtual Revolut card on their platform!


#5

By email they replied, that if using a debit/credit card, charges are made up to the 4th of the following month. If using the portuguese “multibanco” then it is “on the 7th and 28th of the current month”.

And then, yes, there is a 0,10€ fee for “comissão de processamento administrativo” (meaning something like commission for administrative processing) - because they’re not making money on selling the physical ticket.

Only in Portugal…


#6

A bit off-topic, but I’m ok with they charging this commission fee. It is horribly explained, but actually its only charged once on each month when the service is used, so it would cost 1,20€/year - more than the 0,50€ for a paper card, but less than the 5€ that they charge on a plastic card (the only one that supports passes of any kind). It is worth for the convenience. However they got a hefty EC grant, so they shouldn’t be making money anyhow imho…

About the issues with Revolut, was any explanation given to why the 0,10€ was successfully charged but the transportation costs were not? I honestly think that they are screwing up the processing here, it makes no sense for one operation to go through and the other, using the same card, just fail. Since you got a reply from their customer service could you follow up with this question?


#7

I haven’t personally tried the app. As it is also pretty recent (days), I’m going to give it a couple of weeks or so, and then try it for myself, so that I can either “prove” that it works OR have my own “proof” that it doesn’t, and then I can reach out to their team.

Anyway, they were pretty fast in getting back to me (on my email about tariffs), so if anyone is reading this and is being affect, please do send them an email at anda@linhandante.com .