Double currency exchange on top-up


#1

I already reported this and it’s being investigated, but I had a nasty surprise. I topped up my Revolut account in my local currency (RON) and the transaction was made through EUR (I got a RON-EUR-RON conversion), which isn’t quite what I hoped for. My bank is Unicredit.

So if you’re new, you might want to hold off a little until you’re sure you won’t run into this kind of issue.

EDIT:
@redi card.
@redi I topped-up my RON account from a RON card. There should have been no currency conversion. The transaction shows up as:

POS purchase 100,00 RON 21,88 EUR @4,7000 EUR-RON

Which indeed shows that Revolut asked for 100 RON.


Are there any Revolut users in Romania?
#2

What kind of top up?
By card or via wired transfer?


#3

ok, so it looks like currency mismatch.
Please try to take care about currency during whole process (if you have chosen Top up on right wallet and then if it hasn’t changed during process)


#4

Card. It shows up as:

POS purchase 100,00 RON 21,88 EUR @4,7000 EUR-RON

#5

Wait a sec.
Do you mean this?
I you’ve tooped up by RON
You’ve tried to pay in RON
During payment it appeared that it was exchanged from EUR to RON?
If I’m right it looks like DCC


#6

I tried to top-up a RON Revolut account from a RON card and the transaction was performed in EUR. I believe that’s an attribute of the transaction. Maybe the transaction currency wasn’t set (is that possible) and my bank chose to use EUR.


#7

Probably your card is recognised as EUR and that’s why it could be charged in EUR by shop.


#8

Which shop do you mean?


#9

Can you check the details Revolut has stored about your card?

Tap top up, then the app shows you the card last used. It also shows you the currency of that card there, deprived from the country code of the card number, I assume.

Does it show RON or EUR there?

If RON, I believe this is a bug. If EUR, the app should ask you when topping up if the preselected currency is indeed the currency you want to top up in because it believes your card is a EUR card. Ironically, this is to help you avoid fees. But it’s tricky.


#10

@Frank it shows RON as the card currency.


#11

If you’re sure that you also preselected RON for the top up, this seems to be a software bug. I guess you need to talk to support and ask them to investigate.


#12

I did, which is why I said it’s being investigated in the original post. The answer from support chat was:

[…] it seems that the bank is recognising your payment incorrectly therefore applying the exchange rate when it is not necessary. We are investigation the issue in order to come up with a solution that can be presented to the bank […]


#13

Hi . What’s about your problem. It is had solved? I have the same situation . Nobody help , nothing explain


#14

It’s only been three days or so. Looking through the forum threads, I see other issues left unanswered since last summer, so I’m a little pessimistic.

Are you having issues with the same currency (RON) (guess not, seeing your name) or bank (Unicredit)?


#15

Yes, Unicredit group. I asked in revolut chat. I payd a few times at the store and everything was good. Only when I pay by website . On the chat Revolut they told that is website foult - Ryanair, but I dont belive so much because my friend has the same situation. Hi dont have acount in Unicredit. Now I dont know can I pay on internet or not.

Marzena Poland


#16

I don’t know how it looks like on Ryanair, but for sure you can have similar problem on Amazon, Wish, Geek, Alliexpress, Gearbest and so on. (using Paypal- additionally risk :slight_smile: )
This behavior ALWAYS depends on settings on each particular service.


#17

I think your issue is different. I got the extra conversions when topping up my Revolut account with my Unicredit card, not when buying something.

DCC was mentioned here in this thread. Try to be careful when the shops or sites offer you to choose the currency.

I recall WizzAir doing something like that (showing me ticket prices in RON, but making the transaction in EUR).


#18

100% agree. BTW. do you have any response from support?
After this :slight_smile:


#19

100% agree. BTW. do you have any response from support?

Ah, no, it’s only been three days. Even activating my account took longer than that. Seriously, reading through the forum, I’m starting to believe it will never be fixed.


#20

I’ll summon @AndreasK in here.
He does miracles for us :slight_smile: